When I try to start bamboo with the bamboo user, it simply doesn't start. When I look in catalina.out.log, I get the following error and I can't access bamboo via its url:
Aug 03, 2015 11:01:43 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
Aug 03, 2015 11:01:43 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8085"]
Aug 03, 2015 11:01:43 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 570 ms
Aug 03, 2015 11:01:43 AM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
Aug 03, 2015 11:01:43 AM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.40
Aug 03, 2015 11:02:12 AM org.apache.catalina.core.StandardContext startInternal
SEVERE: Error listenerStart
Aug 03, 2015 11:02:17 AM org.apache.catalina.core.StandardContext startInternal
SEVERE: Context [] startup failed due to previous errors
Aug 03, 2015 11:02:17 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8085"]
Aug 03, 2015 11:02:17 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 34063 ms
However, when I start bamboo with sudo, it works. I can't run bamboo using sudo because some scripts in my deployments need to be run without sudo.
I am using bamboo 5.7.2