Bamboo Server v7.2.4 / IIS 10
Setup a reverse proxy in IIS so my team can access our Bamboo instance on a user-friendly URL. This is working perfectly everywhere except for the Deployments page where I see this error:

The release statuses never load, showing the "waiting" spinner indefinitely.
In the Network tab of dev tools, I see 403 errors for each access to [server-name]/rest/api/latest/deploy/dashboard/status -- the server's response for each of these is "XSRF check failed".
I have tried unchecking "Enable XSRF Protection" in Security Settings and this has no effect.
Can anyone advise on specific IIS settings to pass along CSRF tokens correctly? I do not need a general setup guide for ARR/reverse proxies; this is a more specific error.
Alternatively, can anyone advise on truly disabling XSRF protection in Bamboo? Options in Security Settings have not been effective.