After Upgrading crowd from Version 4.0.0 to the new Version 4.1.1, error when loading the "Audit log" and "Users" in Browser and Support Zips can't be created with same error also.Before Upgrading to 4.1.1 it was working.
2020-08-31 14:19:36,031 http-nio-8095-exec-30 WARN [common.security.jersey.XsrfResourceFilter] Additional XSRF checks failed for request: http://domain.com/rest/admin/latest/users/search , origin: https://domain.com , referrer: https://domain.com/console/secure/user/browse.action , credentials in request: true , allowed via CORS: false2020-08-31 14:19:50,922 http-nio-8095-exec-22 WARN [common.security.jersey.XsrfResourceFilter] Additional XSRF checks failed for request: http://domain.com/rest/admin/1.0/auditlog/query , origin: https://domain.com , referrer: https://domain.com/console/secure/auditlog/browse.action , credentials in request: true , allowed via CORS: false2020-09-01 07:21:48,097 http-nio-8095-exec-22 WARN [common.security.jersey.XsrfResourceFilter] Additional XSRF checks failed for request: http://domain.com/rest/analytics/1.0/publish/bulk , origin: https://domain.com , referrer: https://domain.com/plugins/servlet/troubleshooting/view/ , credentials in request: true , allowed via CORS: false2020-09-01 07:21:59,735 http-nio-8095-exec-30 WARN [common.security.jersey.XsrfResourceFilter] Additional XSRF checks failed for request: http://domain.com/rest/troubleshooting/latest/support-zip/local , origin: https://domain.com , referrer: https://domain.com/plugins/servlet/troubleshooting/view/ , credentials in request: true , allowed via CORS: false
We have already checked the proposed solution, but we do not have a proxy in use: https://confluence.atlassian.com/crowdkb/error-when-loading-the-audit-log-in-crowd-961801639.html
Thanks in advance!
Regards,
Olaf
Problem solved:
I've add the following scheme into server.xml:
scheme="https"
Now it works
It looks like you're new here. Sign in or register to get started.