※ This article was updated on Oct 15, 2019. utf8mb4 is required for Jira 8.12 or later. ※
Unable to start Jira with "The database setup is not supporting utf8mb4" error.
This Knowledge Base article was written specifically for the Atlassian Server platform.
Problem
The following error message was displayed when start-up Jira Server.
Database: We've found an error in MySQL supported version!
The database setup is not supporting utf8mb4
See our documentation for more information on setting up MySQL 5.7.
Cause
Since utf8mb4 is officially supported from JIRA 8.x and MySQL version 5.7
When the user selects Database Type MySQL 5.7+ in the setup wizard, dbconfig.xml automatically set database type to mysql57.
This dbconfig.xml configuration let Jira expect to use utf8mb4 Collation and Character.
<database-type>mysql57</database-type>
Resolution
Always backup your data before performing any modifications to the database.
Use utf8mb4
Please follow the below link and update the Database collation, character, and my.cnf .
Use utf8
<database-type>mysql</database-type>
Please follow the below link and update Database collation, character and my.cnf .