I'm trying to install FishEye on a Windows server using a service run as an unprivileged user. I have followed the FishEye install guide and the install-as-service guide. But I cannot start the service.
I have C:\FishEye\Program as <FishEye home directory> and I have C:\FishEye\Data for the instance data. FISHEYE_INST is set to the latter path. The service is setup to run as the fisheye user. The fisheye user has RO access to Program, and RW access to Data. The guides does not specifiy if there are any directories within Program that should be RW (which Jira does).
How is intended to use the wrapper script is to be used in regards of permissions? According to the guide the wrapper is to be installed under Program. Yet when I start the service it fails because it has no RW access to the Program directories. What am I missing here?