After upgrading from 6.6 to 6.8, my remote agent is unable to connect to the server. The agent log in the bamboo UI just lists that the remote agent is loading over and over.
Agent atlassian-bamboo log:
2019-02-26 13:06:14,015 WARN [AgentRunnerThread] [FailoverTransport] Transport (tcp://<domain omitted>:54663?wireFormat.maxInactivityDuration=300000) failed , attempting to automatically reconnect: java.io.IOException: Wire format negotiation timeout: peer did not send his wire format.
Catalina.out
2019-02-26 19:08:48,409 WARN [http-nio-8085-exec-14] [AuthorizationLoggerListener] Authorization failed: org.acegisecurity.AccessDeniedException: Access is denied; authenticated principal: org.acegisecurity.providers.anonymous.AnonymousAuthenticationToken@9055e4a6: Username: anonymousUser; Password: [PROTECTED]; Authenticated: true; Details: org.acegisecurity.ui.WebAuthenticationDetails@957e: RemoteIpAddress: 127.0.0.1; SessionId: null; Granted Authorities: ROLE_ANONYMOUS; secure object: com.atlassian.bamboo.configuration.agent.AddRemoteAgent@1e08960; configuration attributes: [WW_ADMIN, WW_RESTRICTED_ADMIN, GLOBAL_READ]
After seeing this authorization failure, I attempted to revoke access to the agent, then restarted the agent. Upon restarting the agent, it was listed in the Agent Authorization tab pending authorization. After approving the agent, it still fails to connect with the above "peer did not send his wire format" message.
Now, the Catalina.out messages just say:
2019-02-26 19:20:41,379 INFO [http-nio-8085-exec-12] [RemoteAgentManagerImpl] A remote agent is loading on <domain omitted> (127.0.0.1).
It should be noted that I am using a reverse proxy via Apache which is why the IP address is listed as 127.0.0.1. However, I have 127.0.0.1 listed as an approved IP address for the agent.