The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 

LFS > 100 MB fails to push to azure devops

Deleted user
May 2, 2024

Hi, all. I managed to set up a remote azure dev ops repo and push/pull without issue from a couple of windows laptops. I then initialized LFS and was still able to push/pull small tracked LFS files. However, any LFS tracked file type larger than ~100MB fails to push with the following error (partially redacted): 

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v Azure_Devops_Remote__-_MYPROJECT master:master
fatal: Cannot determine the organization name for this 'dev.azure.com' remote URL. Ensure the `credential.useHttpPath` configuration value is set, or set the organization name as the user in the remote URL '{org}@dev.azure.com'.

Locking support detected on remote "Azure_Devops_Remote__-_MYPROJECT". Consider enabling it with:
$ git config lfs.MYREMOTEURL/info/lfs.locksverify true

In regards to the error, I'm not sure how to "ensure the 'credential.useHttpPath' configuration value is set' but my org name is already set as the remote user in the remote URL. Also, I'm not sure how to enable locking support through Sourcetree. I also tried adding an account under Tools/Options/Authentication and while it was accepted, it didn't help.

I'd be very appreciative of any suggestions to try. Thanks in advance!

2 answers

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Answer accepted
Deleted user
May 3, 2024

This thread contained the answer for me in case anyone else if having the same problem. TLDR - run the line below:

git config http.version HTTP/1.1

I'm not sure how to do that from within Sourcetree, of course, but it seems to fix the issue.

0 votes
Deleted user
May 3, 2024

Still happening.

TAGS
AUG Leaders

Atlassian Community Events