Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I can't close sprint because of a "uncompleted" story that is not even on the sprint.

I can't close one sprint. It says "sprint cannot be completed as there are incomplete subtasks on the following issues: SD-410" But SD-410 is on another sprint (not the one that I'm trying to close". Please help!

2 answers

Daniela - try running a project reindexing and then try closing the sprint again.

Good call, I was wondering if it could be an indexing issue.

Hi Daniela!

A lot of people in my instance of Jira have run into this exact thing! The reason is whenever you have parent issues (issues with sub-tasks under them) on Sprint Board, all sub-tasks under them must also be completed before you can complete the sprint, even if the sub-task is on another board.

So, in order to complete the Sprint, that sub-task will either have to be transitioned into whatever the 'Done' status is, or removed from the parent issue. 

This functionality is described in this article, which also includes other good information about Sprints if you are interested! 

Regards,

Jaron

Thanks Jaron,

That story and its child issues are NOT on the sprint that I'm trying to close. Why is this happening?

Hi,

I'm sorry, looks like I misunderstood your original question. So the parent issue is SD-410, and that issue is not on your sprint. 

It's hard for me to know what exactly the problem might be without seeing it. Any more information you can provide would be great (i.e. the filter query used for the board)

Can you make sure that all issues and sub-tasks related to those issues are in the right-most column of the board? And also make sure that there are no un-mapped 'Done' statuses? Those are most commonly the problem, and it's possible that the error message containing an unrelated issue is an indexing problem?

Hopefully someone else can chime in on this, cause I'm a little stumped. 

Hi,

I'm sorry, it appears I misunderstood the question! So SD-410 is the parent issue and it is not on your board.

It's somewhat difficult for me to diagnose the problem without being able to see it. Any extra information you could provide would be great! (i.e. the filter query used for the board).

Can you verify that all issues are in the right-most column of the board, and that you don't have any un-mapped statuses in the column settings? Those are generally the most common reasons for the error you're getting.

Hopefully someone else will have some ideas, I'm a little stumped on this one.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Admins, notify your Jira instance of system-wide changes with the new admin announcement banner

Hi All! We’re excited to share the launch of an announcement banner that lets Jira site administrators communicate directly to their users across their  Jira Cloud instance.  ...

736 views 17 20
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you