Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,191
Community Members
 
Community Events
177
Community Groups

Remote repository path error, misleading error prompt

Edited

Hi

I am trying to sync my local repository to remote but I get this error. My browser (firefox) is set as default in windows. I get this error when I try to view repository online or when i hit the remote button in the task bar. sourcetreerror2.png

I assume this is why my files in the online repository are really old? I need to get this project onto MacintheCloud so I can publish ios version of project so would really appreciate some help in getting this sorted.

How do i fix?

thanks

3 answers

I found this on another post.  Seems to work:

  • In Sourcetree, click on the "Settings" button, located on the top-right of the screen
  • On the window that opens, in the "Remotes" tab, select your remote and click "Edit"
  • If all the information is correct in that window (it was in my case), simply click "OK"
  • Click "OK" again to close the "Repository Settings" window

That fixed it for me. It seems to me that re-setting the URL of the repository to the same address is what does the trick. I hope it works for you as well.

This worked for me too.  Geez, dumb software...

Like # people like this

In a similar vein, I found that I had to delete and then recreate the 'Remote repository path' settings to make the error go away (with no changes made).

worked, amazing. thanks 

Cheers, That worked.

I tried this and it didn't work.  Are you using the https:// URL format or git@.  I am using the git@ format for Sourcetree access, but https:// for Browser access.

When you clone a project you can choose among 2 protocols: either using git over ssh, or https. I always use git, because I can just use an ssh key and forget about passwords management.

I just tested with a project cloned with https, and the browser is opened correctly. On the other hand, when using git I get the same error as lz7cjc. Looking at the log messages I cannot believe that they are really trying to open a browser at the URL git@gitlab.com:repository/path.git without even checking how the project was configured, and if that string is a valid URL or not.

My Sourcetree still has this problem and I have the latest version (3.4.4).  Please fix this.

"Unable to open your web browser to 'git@git-server.domain.org:repo/project.git' ", it also incorrectly attributes the problem to not having a default web browser (I do have a default web browser == Firefox 78.10.1ESR)

Note I'm obscuring the actual url, but the point is that it's showing it in "git@host.domain:repository/project.git"  URL format.  I do not want to set my git clone urls to https format, I want 'git' (ssh) format.  Sourcetree should really manage a separate https repo link for the Remote button to use with the browser.

Like # people like this

Hello

Has this problem already been resolved?

I'm same problem.

Its not really a problem but rather a misleading error message.  The solution has to do with setting the Repository Details so that when you click on the Remote Icon you will bring up a Bitbucket browser-viewer of your repository. 

The error is misleading because it suggests you haven't setup your default browser.

It should suggest that you setup a https:// url that points to your bitbucket-server.

Search this site for my recently posted fix of this problem.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events