Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,410,342
Community Members
 
Community Events
169
Community Groups

MacOS git flow repo not enabled

Hi,

In attempt to create a new git flow Feature branch in sourcetree, I get the following error 'fatal: Not a gitflow-enabled repo yet. Please run "git flow init" first.'

I am using the embedded Git (version 1.7.11.1). How do I run "git flow init" via the embedded version of Git?

If it helps, here is my .git/config

[core]
        repositoryformatversion = 0
        filemode = true
        bare = false
        logallrefupdates = true
        ignorecase = true
[remote "origin"]
        fetch = +refs/heads/*:refs/remotes/origin/*
        url = http://XXXX.git
[gitflow "branch"]
        master = master
        develop = develop
[gitflow "prefix"]
        feature = feature/
        release = release/
        hotfix = hotfix/
        support = support/
        versiontag = 
[branch "develop"]
        remote = origin
        merge = refs/heads/develop

2 answers

1 accepted

7 votes
Answer accepted

I have worked this out now.

The problem was that I had removed the master branch from my local repository, so git flow was presumably looking for it. Upon not finding it, it thought git flow was not initialised.

It would have been good if it gave me a slightly less cryptic message though...

KieranA Rising Star Apr 10, 2013

Yes git-flow does rely heavily on your branch names. This is very important. The error message you would've received wouldn't have been from us but would have been from git-flow itself. We can't predict what git-flow reports as this could change at any time.

Glad you've got it working

Yes I'll put this one down to being a git newbie

I got this problem when my local master branch where missing.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events