Portfolio Install Issue

When I installed the 30 day trial of Portfolio I could not access any of the plugin's screens. When I went to the Portfolio plugin's Administration page I get a 404 error (see below). I tried disabling and re-enabling the plugin, but that did not change anything. I also tried uninstalling and reinstalling. This did not fix the issue either. In fact, some of the admin links for "Portfolio for Jira" are no longer showing after the reinstall. I do see the "Portfolio Permissions" link (gives 404 error) and the "Portfolio License Details" link (does work, license status is "Valid").  Also - I just started here and noticed that our license expired on Jan 6; my boss is working on the renewal).

Please let me know how to get the Portfolio working properly.



=== Client Info ===

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.109 Safari/537.36 
Local time: Tue Feb 16 2016 09:41:45 GMT-0600 (Central Standard Time)

=== Request ===

URL: /systempermissions/admin.json?_=1455637300528
Type: GET
Status: 404
Data: undefined

=== System Info ===

Plugin build: undefined 

3 answers

Yes, but after fixing this we ended up not using Portfolio after all.

During the first install attempt tables were added to the Jira database. However, subsequent attempts to complete the install failed, but the tables were left. Atlassian support indicated that these tables were causing the issues seen and that the tables needed to be removed. The Atlassian support team provided a script to drop the Portfolio related tables. 

Once I removed the tables everything worked fine. 

If this matches your problem you should probably log a ticket with Atlassian support containing your site's details.  Our database schemas could well be different and it would be best for you to have Atlassian Support provide instructions that you know will work for your install.

Did you solve this issue? I'm experiencing nearly exactly the same thing.

This is similar to a prior bug. Issue JPO-1158 was logged with Atlassian Support team.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events