the following error occurred while importing existing backup data:
Incorrect string value: '\xF0\xA0\xAE\xB7\xE5\x8E...' for column 'NEWSTRING' at row 1
Hi,
Can you look at this KB, it deals with Confluence but i think it may be helpful:
https://confluence.atlassian.com/confkb/incorrect-string-value-error-thrown-when-restoring-xml-backup-in-confluence-777009599.html
Can you make sure that your DB is properly set up:
https://confluence.atlassian.com/adminjiraserver/connecting-jira-applications-to-mysql-8-0-1018775461.html
The string you are seeing there is (probably) a unicode 4 byte encoded character - these were added when we ran out of space in the 3 byte scheme. You usually see them in more recently standardised Emojis.
Sadly, I learned this the same way you have - trying to prep an upgrade, Jira issues were going missing, finding a very similar error. Turns out one of the client's users was fond of using the 💩 emoji when creating new issues.
If it is this, then @Mohamed Benziane has given you the right answer, but I can add "look at the character set first" - if you don't set it as documented, MySQL only supports the 3 byte scheme off-the-shelf!
It looks like you're new here. Sign in or register to get started.