Deleted user February 20, 2020


I updated Jira to lastest version 8.7, but got this message: gadget.common.error.500

Health check message: 


Gadget feed URL

What does this check do?

Checks if Jira is able to access itself through the gadgets feed URL to ensure that dashboard gadgets will work.


Jira is not able to access itself through the Gadget feed URL. This is necessary so that dashboard gadgets can be generated successfully. Please verify the current Base URL and if necessary, review your network configurations to resolve the problem.


I have NGINX pointed to Jira server, settings as bellow: 


<Connector port="8080" maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"
maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"
acceptCount="100" disableUploadTimeout="true" bindOnInit="false" secure="true" scheme="https"
proxyName="" proxyPort="443"/>



server {
listen 443 ssl;

location / {
add_header Front-End-Https on;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;

proxy_pass http://jira.server.ip:8080;
proxy_read_timeout 90;

proxy_redirect http://jira.server.ip:8080;

ssl_certificate /etc/nginx/ssl/comodo/live/;
ssl_certificate_key /etc/nginx/ssl/comodo/live/;


I tried to check atlassian-jira.log but couldnt find anything special about gadget.

As I understand: Jira is able to access itself  is the cause. Trying curl -v within jira server but not success. (other server work fine)

* Rebuilt URL to:
* Trying jira.server.ip..
* connect to jira.server.ip port 80 failed: Connection refused
* Failed to connect to jira.server.ip port 80: Connection refused
* Closing connection 0
curl: (7) Failed to connect to jira.server.ip port 80: Connection refused

Since it worked before updating, I tried copy everything from old server.xml but not success. 


Appreciate any help,


3 answers

1 accepted

0 votes
Answer accepted
MAJ February 24, 2020


try changing the "localhost" to "" then restart start

Deleted user February 24, 2020

Hi Max, 


I changed bellow:

JVM_EXTRA_ARGS="-XX:-OmitStackTraceInFastThrow -Djava.locale.providers=COMPAT -Dhttp.proxyHost= -Dhttp.proxyPort=8080 -Dhttps.proxyHost= -Dhttps.proxyPort=8080"


Same error.


Best Regards.

MAJ February 24, 2020

remove those changes i recommended and post your connection infor from tomcat where you connect via port 8080 also does your firewall permit that port access 

one way to fine out is # firewall-cmd --list-all  port 8080 should be in the ports list.

finally what are the details from executing : # env


Deleted user February 24, 2020

Hi Max, 


I used ufw for firewall but I disabled it in case it affect jira: 
#ufw status
Status: inactive

Can see port 8080 is LISTEN by:
# netstat -tulpn | grep 8080
tcp6 0 0 :::8080 :::* LISTEN 32430/java

This is my #env:

# env
LESSOPEN=| /usr/bin/lesspipe %s
LESSCLOSE=/usr/bin/lesspipe %s %s


I dont know how to get connection info for tomcat, can you help?



MAJ February 24, 2020

Nothing really stands out to me. Are your running jira as root ?

if so can make sure Jira owns the files in the home and install directories and the

your problem isn't the application you need to connect to outside from the server did you ever ping google from the cmd line? 

if you can't you need to resolve the network issue. 

0 votes
Deleted user February 24, 2020

Hi Max, 


I have jira installation directory under: /etc/jira and jira home under: /var/jira

Also already run chown jira:jira -R /etc/jira and chown jira:jira -R /var/jira

I actually run jira under root. But I can see jira is running under jira user: 

# ps -elf | grep jira
0 S jira 2470 1 32 80 0 - 980782 futex_ 01:17 ? 00:04:19 /etc/jira/jre//bin/java -Djava.util.logging.config.file=/etc/jira/conf/ -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Xms384m -Xmx768m -XX:InitialCodeCacheSize=32m -XX:ReservedCodeCacheSize=512m -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -Dorg.dom4j.factory=com.atlassian.core.xml.InterningDocumentFactory -XX:-OmitStackTraceInFastThrow -Djava.locale.providers=COMPAT -Datlassian.plugins.startup.options= -Djdk.tls.ephemeralDHKeySize=2048 -Djava.protocol.handler.pkgs=org.apache.catalina.webresources -Xloggc:/etc/jira/logs/atlassian-jira-gc-%t.log -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=5 -XX:GCLogFileSize=20M -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+PrintGCTimeStamps -XX:+PrintGCCause -XX:+ExplicitGCInvokesConcurrent -Dignore.endorsed.dirs= -classpath /etc/jira/bin/bootstrap.jar:/etc/jira/bin/tomcat-juli.jar -Dcatalina.base=/etc/jira -Dcatalina.home=/etc/jira org.apache.catalina.startup.Bootstrap start


This is status jira now: 

root@hostname:/etc/jira/bin# systemctl status jira

● jira.service
Loaded: loaded (/etc/init.d/jira; bad; vendor preset: enabled)
Active: active (running) since Tue 2020-02-25 01:17:30 UTC; 12min ago
Docs: man:systemd-sysv-generator(8)
Process: 2312 ExecStop=/etc/init.d/jira stop (code=exited, status=0/SUCCESS)
Process: 2428 ExecStart=/etc/init.d/jira start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/jira.service
└─2470 /etc/jira/jre//bin/java -Djava.util.logging.config.file=/etc/jira/conf/ -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Xms384m -Xmx768m -XX:I

Feb 25 01:17:30 ausy-fe-jira-m1 jira[2428]: `UOJ
Feb 25 01:17:30 ausy-fe-jira-m1 jira[2428]: [1B blob data]
Feb 25 01:17:30 ausy-fe-jira-m1 jira[2428]: Atlassian Jira
Feb 25 01:17:30 ausy-fe-jira-m1 jira[2428]: Version : 8.7.1
Feb 25 01:17:30 ausy-fe-jira-m1 jira[2428]: [19B blob data]
Feb 25 01:17:30 ausy-fe-jira-m1 jira[2428]: If you encounter issues starting or stopping Jira, please see the Troubleshooting guide at
Feb 25 01:17:30 ausy-fe-jira-m1 jira[2428]: Server startup logs are located in /etc/jira/logs/catalina.out
Feb 25 01:17:30 ausy-fe-jira-m1 jira[2428]: Tomcat started.
Feb 25 01:17:30 ausy-fe-jira-m1 runuser[2435]: pam_unix(runuser:session): session closed for user jira
Feb 25 01:17:30 ausy-fe-jira-m1 systemd[1]: Started jira.service.


Ping google before, as well as Atlassian Marketplace

root@hostname:/etc/jira/bin# ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=56 time=1.29 ms
64 bytes from ( icmp_seq=2 ttl=56 time=1.20 ms
64 bytes from ( icmp_seq=3 ttl=56 time=1.16 ms


Best Regards.

MAJ February 24, 2020

try the curl command to the market place

Deleted user February 25, 2020

curl -v ""
* Rebuilt URL to:
* Trying
* Connected to ( port 80 (#0)
> GET / HTTP/1.1
> Host:
> User-Agent: curl/7.47.0
> Accept: */*
< HTTP/1.1 200 OK
< Server: nginx


<noscript>This site requires JavaScript and Cookies to be enabled. Please change your browser settings or upgrade your browser.</noscript>
* Connection #0 to host left intact

MAJ February 25, 2020

Look at that! :) 

looks like it's working bring up the system and check the connection within the application. 

also please like my response if all goes well 


Happy Tracking! :) 

Deleted user February 25, 2020

Hi Max, 


I actually could curl marketplace before and the gadget still get error. 


Anyway, I found an solution, thanks for your response about HTTP proxy. I add my proxy in and fixed it. Don't know why it need proxy for it, since that server has internet connection already.


Problem solved.

Thanks Max

0 votes
MAJ February 21, 2020

Dear User 

Are you using a proxy to access the internet within your organization? 

If so you will need to make sure the proxy is configure to allow the application to access marketplace.  Compare the setting on the server experiencing this problem with the others that appear to be working fine. 

Good Luck 

Deleted user February 23, 2020

Hi Max, 

Thanks for your quick response. 

I didn't put any proxy on Server, and it also has internet. How can I test access marketplace exactly? and which file should I compare? 

I tried to transfer everything in server.xml, issue still there. 



MAJ February 24, 2020


From the command line in linux execute the following command:

# curl -v ""

If your response is an error your connection/application is not getting to the internet. This is a network problem you will need to resolve.

off the top of my head I would recommend the following checks:


  • Check your network connection and or restart or reload it.
    • /etc/init.d/network restart(Redhat)
    • sudo systemctl restart network (CentOS)
  • Try pinging something like if you get a response then your getting out so you may need to debug using traceroute.

I don’t want to recommend much more beyond this because I’m not a network engineer but start there and let us know.


Kind Regards

MAJ February 24, 2020

After doing a little more digging, try this: 

Edit the file located in your install directory under /jira/bin/
add the following to the JVM_EXTRA_ARGS
-Dhttp.proxyHost=localhost -Dhttp.proxyPort=8080 -Dhttps.proxyHost=localhost -Dhttps.proxyPort=8080

Deleted user February 24, 2020

Thanks Max, 

1. curl -v "" reply with the web content, seem like internet ok
* Rebuilt URL to:
* Trying
* Connected to ( port 80 (#0)

2. I restart network

3. edit as bellow:

JVM_EXTRA_ARGS="-XX:-OmitStackTraceInFastThrow -Djava.locale.providers=COMPAT -Dhttp.proxyHost=localhost -Dhttp.proxyPort=8080 -Dhttps.proxyHost=localhost -Dhttps.proxyPort=8080"

4. Restart jira


Now they showing different error: gadget.common.config.unavailable

This is the log error I get:

2020-02-24 20:27:02,792+0000 analyticsEventProcessor:thread-1 ERROR admin [c.a.a.client.listener.ProductEventListener] Failed to send analytics event
com.atlassian.cache.CacheException: com.atlassian.util.concurrent.LazyReference$InitializationException: Provider for class cannot be created


Caused by: java.util.ServiceConfigurationError: Provider com.ctc.wstx.stax.WstxInputFactory not found


I can't understand this log, so if you need anything else, please let me know.



Deleted user February 24, 2020

Also after edit, I have error: 

The Atlassian Marketplace server is not reachable. Available application updates will not appear on this page.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events