Why is the javascript in Field Configuration not executed anymore?

Service
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 3, 2020

We use Jira Core since About 2 years.

In some of our Workflows we used the Field Description of the Summary field to automatically fill and hide it.

Here's the relating script:

<script type="text/javascript">
 jQuery("label:contains('NoSummaryField')").parent().hide();
 jQuery("input#summary").parent().hide();
 jQuery("#create-issue-submit").click(function(){
  // TODO: fetch ur summary value here
  var summary_value = "Neuer Vorgang";
  jQuery("input#summary").val(summary_value);
 });
</script>

 Unfortunatly since we updated to Jira Version 8.7.1, the script seems not to be executed anymore but is shown on the create issue screens.

2020-03-03 14_07_10-Create Issue - Jira - NEW Netz GmbH.png

With Version 8.6.1 the description wasn't shown and the script was executed.

 

2 answers

8 votes
Dawn Fama March 12, 2020

Try this:

Disabling HTML in custom fields description

Status: IMPLEMENTED (eap 02)

We’re changing the default behavior of one of the global settings: Enable HTML in custom field descriptions and list item values. Now, it will be OFF by default. If your instance relies on having this option enabled, make sure to change it in Administration > System > General configuration.

https://confluence.atlassian.com/jiracore/preparing-for-jira-8-7-983794309.html

Mohammed Siyad June 30, 2021

Hi Dawn @Dawn Fama ,

I have just upgraded to 8.13 version, here still this JS shows up in this area and it is already disabled by default. Will this issue be solved if we enable it? Or is there any other alternate workaround for it?

Dawn Fama June 30, 2021

Hello Mohammed,

Sorry for any confusion.  I'm not an Atlassian developer.  I'm just part of the community. 

I copied the response above from the sited link - Preparing for Jira 8.7 | Atlassian Support | Atlassian Documentation

Have you tried to enable to see if it works as expected?  

Also, maybe full re-index may help after upgrade?  Are you using built in jvm or other jvm?  

Currently, I'm running 8.16.1 on my instance.

Like Mohammed Siyad likes this
Mohammed Siyad July 1, 2021

Thanks dawn, it worked out for me in 8.13.4 version after the re-index. Thanks aton for the info.

Like Dawn Fama likes this
Dawn Fama July 1, 2021

Great!  Glad it's working for you :)

Francesco R
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
November 19, 2021

I had the same issue. Thanks @Dawn Fama , it worked for me in 8.20.1 also without reindexing.

0 votes
Dawn Fama March 12, 2020

I have an identical issue with JS rendering for custom field

Suggest an answer

Log in or Sign up to answer