Why has my automation stopped working?

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

The automation is set to transition a parent issue to Selecting MO Tasks if its current status is Waiting for BA Tasks, when the issue’s sub-task is transitioned from Dev Task Assigned to Dev Task Completed.

It was working until I modified fields, screens and workflows.  The error mentions a problem with the destination status, but I don’t see a problem with the status name, so I’m guessing there’s a hidden problem such as a screen missing an association.

Automation log error:

Transition issue

Destination status could not be resolved. If using a smart-value ensure this resolves to a numeric status ID or untranslated name for issues (with current status):

TAST6-1025 (Waiting for BA Tasks - 10200)

Relevant piece of automation:

automation 3-24.jpg

Relevant parent workflow statuses:

Workflow 3-27.jpg

Relevant sub-task workflow statuses:

subtask workflow 3-27.jpg

1 answer

1 accepted

0 votes
Answer accepted
Bill Sheboy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

Hi @Phil Bustin 

I hypothesize the problem is the rule is using the status id values behind the scenes.  Let's try this:

  • disable the rule
  • edit the rule to change the transition and condition to check other status values
  • save/publish the rule
  • edit the rule to set the values back to what you need
  • save/publish the rule
  • re-enable it, and test

Kind regards,
Bill

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

I had already tested re-entering the one destination status value, but I'll try what you suggested.

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

In the error message, which mentions numeric identifier, the status listed (with numeric identifier) is the From status, not the To status.  Also, is there a way of seeing the numeric identifier of a status to try to debug this?

Also, which statuses were you suggesting that I change back and forth in the automation?

Bill Sheboy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

Yes; you could export the rule to JSON and look at the details of the values used.

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

I tried that and didn't see an identifier for "Selecting MO Tasks", but then, I don't know how to use the tool, and I apparently don't have Visual Studio installed.

So far, I changed the status "Selecting MO Tasks" to another status that is connected by transition to "Waiting for BA Tasks", turned it on, published it, tested (same error), turned off, put back "Selecting MO Tasks", published, tested--same error.  So since the error mentions "Waiting for BA Tasks", and not the actual destination status, I'll try changing the "Waiting for BA Tasks" status.

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

Near as I can tell, I followed  the procedure you outlined, but the error remains.  When I changed the status from "Waiting for BA Tasks" to "Developer Assigned", there was no error, although of course the rule took no action.

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

Is there another way of viewing the status numeric identifier, such as looking at the URL when viewing the status?

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

I changed the condition from

   Issue matches JCL > status = "Waiting for BA Tasks"

to 

   Parent matches status = "Waiting for BA Tasks"

There was no error, but the sub-task condition "If Sub-tasks match status = "Dev Task Completed", that comes before the "Waiting for BA Tasks" status condition (the one that was mentioned in the original error) did not match the issue.  Please confirm from the screen shots below:

Beginning of automation

rule 3-27 12-19.jpg

 

The status of the only sub-task created by the parent issue

sub-task completed status.jpg

 

The Rule condition that is not matching

Rule condition not matching.jpg

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

The second branch of the rule worked, and I didn't see any difference between the first and second branch.  However, it didn't work when I used the newer 'related issues' condition of the status, so I reverted to the JQL condition, for both branches, and now the first branch works.  No clue as to why it didn't work all day until now, or why the JQL status condition works but the related issues status condition doesn't.

Automation second branch

rule part that works.jpg

Bill Sheboy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 27, 2023

I am glad to learn you got that to work...And, I have not had much success with the Related Issues Condition, so I normally stick to either JQL ones or advanced compare on specific issue/lookup issues fields.

The issue (no pun intended :^) with the related issues condition seems to be context-related when inside of a branch.

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 28, 2023

Good to know!  Thanks.

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 28, 2023

Unfortunately, seemingly the same as yesterday morning, the automation has inexplicably stopped working.

I'm now not sure which log message belongs to which condition or action.  Below is a screenshot with my added arrows from this morning.

I wonder if I somehow changed one transition name to another some time ago, because unless the log message relates to the JQL condition, despite the message including the word "destination", the status name is wrong.

I sure would like to know if the message refers to the JQL condition or the Transition action, but either way, I don't understand how this could work and then stop working.

automation 3-28.jpg

Phil Bustin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 28, 2023

And the answer is (obvious now--it was the only thing I changed): I had restricted the transition to the destination status--yesterday to Admins; today to a field value.

I removed the restriction, and the automation is working again.

Like Bill Sheboy likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events