Unable to login with LDAP active directory after upgrade to 8.22.3

Michael DeGroot June 6, 2022

I upgraded Jira Core to 8.22.3 and I am now unable to login with my active directory accounts.  

I logged in with the recovery account and test the remote directory connection.  All of the steps complete except the user authentication.  I get this error:

 

Test user can authenticate : Failed
org.springframework.transaction.CannotCreateTransactionException: Could not create DirContext instance for transaction; nested exception is org.springframework.ldap.AuthenticationException: [LDAP: error code 49 - 80090308: LdapErr: DSID-0C090439, comment: AcceptSecurityContext error, data 57, v4563]; nested exception is javax.naming.AuthenticationException: [LDAP: error code 49 - 80090308: LdapErr: DSID-0C090439, comment: AcceptSecurityContext error, data 57, v4563]
For more information regarding LDAP error codes see Troubleshooting LDAP Error Codes.
I tried resetting my service account's password with no effect.  The user passwords are correct and can authenticate as regular logins.

5 answers

1 vote
Thomas NICOLAZIC June 8, 2022

I'm experiencing the same issue after the update to 8.22.3 ...

All of my users can't connect to jira anymore since this afternoon !

Is there a quick fix or a workaround ? 

1 vote
Michael DeGroot June 8, 2022
  • Update: reverted to my previous version and it's fine. Thinking I'll either try again or update incrementally until it breaks. 
Munjal Patel June 8, 2022
Like # people like this
Thomas NICOLAZIC June 10, 2022

Thanks for this temporary fix !!

0 votes
Gonchik Tsymzhitov
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
November 1, 2022

Nice shot! :) 

0 votes
schoeppi June 10, 2022

The suggested workaround also worked for us, thanks a lot for this!

0 votes
Michael DeGroot June 9, 2022

Update 2: Used Monjal Patel's workaround link and it worked.

  1. Updated to 8.20.8 (i wanted to be sure my version of files were not too far out of date)
  2. Replaced the DefaultApplicationRoleManger files in the web-inf folder per https://jira.atlassian.com/browse/JRASERVER-73875

 

From the link:

2) Permanent Solution: Copy/ Replace the old files of 8.20.8 or earlier in directory "/atlassian-jira-software-8.20.9-standalone/atlassian-jira/WEB-INF/classes/com/atlassian/jira/application"

DefaultApplicationRoleManager$1.class
DefaultApplicationRoleManager$BillableUserCountLoader.class
DefaultApplicationRoleManager$DelegatingSettableFutureTask.class
DefaultApplicationRoleManager$RoleLoader.class
DefaultApplicationRoleManager.class

 

On update to 8.20.9 the error occurred again.  On replacement of the files I was able to login.

Avin Singhal June 24, 2022

Copying the file javax.crypto.spec.SecretKeySpec_1649567443152 from old backup did the job irrespective it has different name , this worked as it belonged to same instance but existing on old infra 

Like # people like this

Suggest an answer

Log in or Sign up to answer