Jira-Slack integration not working when security levels are configured

Edi Buslovich November 12, 2018

Hello,

I configured security level in the app and the slack integration stopped working.

As suggested, I selected the security level in the slack integration settings:

Selection_357.jpg

After doing that, notifications about new tasks and task transitions got back to work, but notifications about comments are still not received. 

Any help will be appreciated.

 

Thanks,
Edi.

 

2 answers

1 vote
Edi Buslovich November 15, 2018

Jira support offered me to add the atlassian-addons-project-access project role to the security level, and it solved the issue. Now comments are received in slack.

Alexandre Teyar October 13, 2022

I am facing the same issue, I have a team-managed project connected to Slack, all our tickets have default permissions and therefore notifications are not received.

If you could kindly share the step-by-step instructions to follow, that would be super! 🙏🏼

0 votes
Petter Gonçalves
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
November 14, 2018

Hello Edi,

As you can see in the screenshot below, I'm able to receive comment notifications on Slack even though my issue is currently with a security level:

Screen Shot 2018-11-14 at 13.40.07.pngScreen Shot 2018-11-14 at 13.42.21.png

That being said, can you double-check if all the users added to the Slack channel are properly added to the Security Levels you configured to your JIRA issues?

I think this might be the problem.

Edi Buslovich November 15, 2018

Hi Petterson, 

 

Thanks for the help!

Not all the users in the channel are added to this security level, but how does Jira know who are the users that subscribed to the slack channel?

Furthermore, how come notifications about new issues are received while notifications about comments are not?

 

Thanks,

Edi

Like # people like this

Suggest an answer

Log in or Sign up to answer