Incorrect issue created on workflow transition

Pete P
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
December 14, 2020

In my workflow when I move a story back to DEV from QA I have a defect screen that is launched.   There is a separate issue type called "Defect" I am using.  If I move a "Story" issue type the "Defect" screen is opened however the Issue type is "Story" instead of "Defect" as I would like.  What am I doing wrong?  

1 answer

1 accepted

1 vote
Answer accepted
Callum Carlile _Automation Consultants_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
December 14, 2020

@Pete P It may be that the two issue types are mapped to the same workflow, so any transition screens will be seen for all issue types mapped to that workflow. You can check the workflows the issue types are mapped to by going to Project Settings > Workflows.

If they are sharing a workflow, you might need to

  1. Make a clone of the workflow
  2. Edit the cloned workflow by removing the transition screen you're wanting to hide for Story issues
  3. Associate the Story issue type to the new workflow through Workflow Schemes.

Hope this helps!

Pete P
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
December 14, 2020

@Callum Carlile _Automation Consultants_  thanks that makes total sense.  :)

Like # people like this

Suggest an answer

Log in or Sign up to answer