How to specify a specific Issue Type during CSV Import

Robert Wallace February 28, 2021

Atlassian provides this help on CSV import.  But HOW do you actually specify in the CSV file you want the upload to create a specific Issue Type?

 

Issue Type

If not specified in your CSV file, imported issues will be given the default (i.e. first) Issue Type as specified in your Jira site.

3 answers

1 accepted

6 votes
Answer accepted
Bastian Stehmann
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 28, 2021

Hi,

You can just add a column to your csv where you have the issue type.

While importing, you can then map that column to the issue type. Make sure to check the checkbox for mapping the values. Then you can select which value in that column should be mapped to which issue types. 

IT Web Technologies February 15, 2022

Hi,

This sounds promising but it's just not working. As can be seen in the screenshot below, we're not presented with Issue Type as a mapping target. 

The file importer is recognizing the raw data but we're unable to map it to anything. 

 

Jira Mapping.png

For what it's worth, we're using a very simple file and have tried different combinations of recommendations from the article below to no avail. 

https://confluence.atlassian.com/jiracoreserver0811/working-in-a-project/working-with-issues/creating-issues-and-sub-tasks/creating-issues-using-the-csv-importer

Sample Data

Summary, IssueType, Description
Epic Summary, epic, Epic Description
Bug Summary, bug, Bug Description
Task Summary, task, Task Description

We have tried with and without a default Issue Type. It successfully creates 3x the default when one is specified or 3x the first issue type in the scheme when the default is set to None. 

 

Using Jira v8.13.10

Like # people like this
Robin Silk
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 17, 2022

Hello, did you ever resolve this issue of Issue Type not being presented? I am having this same problem, where I cannot map to Issue Type.


Thanks!

Raymond Canzanese
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 9, 2022

Echoing that although it is the accepted answer, it doesn't work be issue type doesn't appear as a field that can be mapped to.

Will Sargent November 16, 2022

using IssueType as a csv column header will reveal the "Issue Type" field mapping.  Not great behavior, but it works.

Joshua Sims
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 23, 2022

I had to include 'Issue Type' in all the Create screens for the issues that you're trying to import

Like # people like this
Karl Samson December 6, 2022

@Joshua Sims I had to do the same, but like Will said, it works! :)

Paul A Wright May 11, 2023

Thank goodness for this forum.  Adding 'IssueType' as a field header and then doing the import saved me so much trouble.

Thank you all.

Like Karl Samson likes this
2 votes
Neil Monroe March 30, 2022

The only way I have found to resolve this is to have a project user with "Administrator" level status do the import from the System settings using the "External System Import" feature.

If you are not able to get Admin access to the project, then your import will be limited to the fields available in the drop down menus during field mapping.

Assuming you can get elevated account access, you would:

1. Login and go to the settings icon in the upper right and select "System".

Screen Shot 2022-03-30 at 7.43.12 PM.png

2. Select the "External System Import" option from the left navigation.

Screen Shot 2022-03-30 at 7.43.34 PM.png

3. Select "CSV" from the import formats.

Screen Shot 2022-03-30 at 7.43.48 PM.png

4. Proceed to completing the import as usual. You will have tons more field options to choose from, so use the combo box to find the field name you need. "Issue Type" should be one of these.

You will know that you are in the admin version of the import because you will see the "Advanced" options on the first screen.

Screen Shot 2022-03-30 at 7.44.08 PM.png

Once you have a tested, working import, you can save the configuration at the end of the setup. This can be used by checking the box on the first step of the import to use an existing configuration file. You won't need to re-map the fields again. It is useful if repeating the same import process with different data.

Hope this helps!

Karl Samson November 8, 2022

Hey thanks Neil! That has resolved our issue also. Do you know if Atlassian have a fix in the pipeline?

Neil Monroe November 8, 2022

I don't necessarily know if this needs a "fix" other than a different type of task access that would include import as an action that a specific role could perform. Right now only Administrator level has this access.

It is a delicate situation because you don't want just anyone doing these types of mass imports. The solution, in my mind, would be to have more fine-grained role support, but that doesn't seem to exist right now.

I'm not sure if that is in the Atlassian roadmap anywhere.

Karl Samson November 8, 2022

I'm a System Administrator and I still cannot do it from a Project, that I have full access to! I can, however, do it from the System area, as you suggested, so thanks for the tip. Ordinarily, we would want Project Admins with extended privileges to be able to do this by themselves, so holding out for a fix! 

Like Matthaus Lomberg likes this
1 vote
Cory Coleman
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 3, 2023

Hello,

I was having the same issue. After running an import that didn't associate the Issue Type based upon mapping in the .csv file, I saved the configuration file. Next, I was able to analyze the configuration file for a pattern. I then added the following to the configuration file.

},

"Issue Type" :  {

  "jira.field" : "Issue Type"

 

Upon adding the syntax above to the configuration file, I was to successfully import while the 'Issue Type' being properly categorized based upon what was in the import file.

I had been having this issue for several months. Glad to have discovered this workaround! :)

 

Summary:

  1. Run import as you normally would
  2. During the validation phase, download and save the configuration file
  3. Open the configuration file
  4. Add the following to the configuration file
    • },

      "Issue Type" :  {

        "jira.field" : "Issue Type"

  5. Save the configuration file
  6. Retry the import using the modified configuration file
  7. Check your log for accuracy.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events