Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot view Jira issues from BitBucket though I am sole Site/Project owner/admin.

Hi, I have an existing (years old) BitBucket project. I've migrated the Issues to Jira (free). I can access the Jira issues from the Jira site itself. The repo and Jira are also linked as far as I know because I am able to reference Jira issues from repo commit messages. 

The problem happens when I want to view a Jira issue from within the BitBucket interface. I get this message: "You don't have access to this issue - Make sure the issue exists in this project. If it does, ask a project admin for permission to see the project's issues." (screenshot below, showing the issue I clicked on).

I created this setup, there are no other admins to contact. I will be including other's soon, once I work out how this all works. 

I used the Permissions Helper in the '[Jira site] > OGS [Project name] > Project Settings > Permissions' and it shows this: 

"Status:Ben Hutchings has the 'Browse Projects' permission" 

also:

"Ben Hutchings is not a member of the atlassian-addons-project-access project role -You can change this by going to the 'OGS' project roles  and adding Ben Hutchings to the missing role(s)". see Screeny.

When I visit this 'project roles' section I am told that "Project roles aren't editable in Jira Software Free" (see screeny).

So.. I'm a bit stuck. What have I done wrong please? 

Thanks! 

 

no-jira-issue-permission.pngperms-helper-1.pngroles.png

4 answers

1 accepted

11 votes
Answer accepted

Following on to @Blai Pratdesaba finding about Brave, I took a closer look at my experience with Safari on a Mac. If I go to Safari > Preferences > Privacy and turn off "Prevent cross-site tracking," then this feature works.

It turns out this is a known issue with Bitbucket Cloud (see BCLOUD-19971).

Unfortunately, Safari does not allow turning on and off tracking on a per-site or per-tracker basis. It seems that Atlassian is using New Relic to track our use of Bitbucket and without this New Relic tracking the Bitbucket/Jira link is not functional.

I turned "Prevent cross-site tracking" back on and I sincerely hope that Atlassian finds another way to support showing Jira data in Bitbucket. I am puzzled as to why a simple REST API or some such does not do the trick without the tracking.

Thank you this worked ! 

Let's hope there will be an update to allow turning on and off tracking on safari per website in the future.

That is not at all my hope. I am *glad* that Safari enforces cross-site privacy. My hope is that Atlassian fixes this so that cross-site tracking is not required to simply follow a link to a Jira issue.

I don’t know why they don’t just let Jira links be simple links as they are already for the internal Bitbucket issue tracker. I don’t really need or want a pop-up window.

Like # people like this

@efc Wow, fantastic and thank you for finding it out and sharing the info with us. 

I am not going to turn off the cross-site privacy feature, but I am now satisfied to understand the issue there. 

 

I don’t know why they don’t just let Jira links be simple links as they are already for the internal Bitbucket issue tracker. I don’t really need or want a pop-up window.

Oh, I can't agree with you more. I also don't need a pop-up and I just want a direct link, too.. 

Great work @efc , and thanks for finding the Bug ticket too. 

Thanks, Perfect solution for Safari

Found this issue and landed here. I did check the permissions suggested by @meredevelopment and everything seemed fine.

It turns out it was Brave browser tracking prevention that was interfering with this. Once I disabled it on bitbucket the ticket preview started working as expected.

Thank you @Blai Pratdesaba for the initial detective work. You've led us to an answer.

Like Blai Pratdesaba likes this

Thanks @Blai Pratdesaba this was super frustrating. I was having the same issue in Brave. For anyone else who experiences this, follow these steps to fix this in Brave:

  • Settings > Shields > Privacy & Security > Cookies & Other Site Settings > Sites That Can Always Use Cookies

Then add the following site:

You should be able to use the JIRA ticket preview at this point. 

You have quite literally the exact same issue that I'm running up against.

Did you ever find a solution?

I work in a small team - and we're all new to JIRA. I find that if I tell the other devs to view the issues in Jira, they can see them (as you show in your screenshots above); but I was under the impression we could manage them from the bitbucket side of things.

Sorry to say It's still happening, and I didn't find a solution. 

Just once, yesterday morning, I was able to view and edit an issue from within BB, but when I tried again later in the day it gave me the same permissions issue. I'd love a fix, if you find one please share! 

Dang. If I stumble across one - I definitely will! Cheers!

Hey, I also have the same issue here, too... 😭

Is there any progress with this issue by any chance? 

Same issue. I can't view any Jira issues from Bitbucket.

I have the same issue.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you