Cannot edit users in the Jira Internal Directory after a system import

Karl Todd Jr October 24, 2022

I'm working on a migration where I am using exported data from Jira Cloud (generated for server) to restore a Jira server instance. I then enabled the recovery_admin to be able to edit the users despite not having a login in any of the migrated user accounts. 

 

The only problem is I can't edit the Jira Internal Directory at all. I cannot add users. I cannot edit existing users. It's behaving like a read-only directory, but I don't understand how that can be the case. In performing the restore Jira had no issue writing the users into the database in the first place. Just in case, I updated the jdbc driver as suggested in similar articles, but with no luck. The FS permissions were verified to be owned by the user that runs the application. The dbconfig.xml has the correct schema for the database. I have never seen this issue before and cannot find anything about it online either.

2 answers

1 accepted

1 vote
Answer accepted
Eugen Zwinger _demicon_ November 3, 2022

Actually, I found the root cause and was able to resolve this issue for me. The table "cwd_directory_operation" was blank after Cloud import. I've added the needed entries and now I can create/update users and groups. This KB article helped a lot:

https://confluence.atlassian.com/confkb/cannot-add-user-because-add-user-link-is-missing-302810865.html 

Eugen Zwinger _demicon_ November 3, 2022

that one is for confluence, but Jira has the same table. I only needed to add the entries listed here:

INSERT INTO `cwd_directory_operation` VALUES (1,'CREATE_GROUP'),(1,'CREATE_ROLE'),(1,'CREATE_USER'),(1,'DELETE_GROUP'),(1,'DELETE_ROLE'),(1,'DELETE_USER'),(1,'UPDATE_GROUP'),(1,'UPDATE_GROUP_ATTRIBUTE'),(1,'UPDATE_ROLE'),(1,'UPDATE_ROLE_ATTRIBUTE'),(1,'UPDATE_USER'),(1,'UPDATE_USER_ATTRIBUTE');

Jira needs to be restarted and it worked afterwards.

Like # people like this
Karl Todd Jr November 4, 2022

Good find! This worked perfectly for me.

Eliza Jamison July 6, 2023

Darn it, all my values are there already.

0 votes
Eugen Zwinger _demicon_ November 2, 2022

Had the same issue as you describe there and also searching for a solution. Have you found any in the mean time, @Karl Todd Jr?

Karl Todd Jr November 4, 2022

I ended up working around the issue, which I do not recommend.

Suggest an answer

Log in or Sign up to answer