API error message on transition: "Could not load FunctionProvider class"

Craig Anderson July 25, 2023

Setup: Jira Server version 9.6.0.

I'm doing a POST to the issue/{issue_id}/transitions endpoint using the Python requests module.  The code works when I post to a test project, but when I post to the production project I get a 400 return code and get an error:

"Could not load FunctionProvider class"

I Googled the error, but didn't find anything relevant.

For information, here is the POST data (tried to format it - that didn't work)

post_data = {
"transition": {
"id": transition_id
},
"update": {
"comment": [
{
"add": {
"body": comment
}
}
]
}
}

1 answer

0 votes
Hyrum Steffensen _Appfire_
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 25, 2023

Hello Craig,

I tried out the POST data you posted and it seems to work fine. Try searching for "Could not load FunctionProvider class". It returns interesting results such as the following:

Workflow action results in "Could not load FunctionProvider"  

It could be that there is a step in the Workflow on your system that references an addon that is no longer installed or is not enabling. Here are some troubleshooting steps:

  • Check the workflow with a step provided by an addon.
  • Restart Jira and look for addons that are not enabling and error messages for clues.
  • Here are some good sections to look at:
    • Starting the JIRA Plugin System
    • User Plugins
    • FAILED PLUGIN REPORT
  • If you have addons that are not enabling, try clearing the plugin cache.
    • Stop the JIRA instance.
    • Delete <JIRA_HOME>/plugins/.bundled-plugins and <JIRA_HOME>/plugins/.osgi-plugins (just these two folders)
    • Restart JIRA. 

Regards,

Hyrum

Suggest an answer

Log in or Sign up to answer