Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Why is it that all of my accounts are showing up as billable hours in the Tempo logged time report?

I created a number of accounts that are tied to account categories that should allow for billable (Capitalized, Billable) and non billable (Internal, Operational) logging of time. When I enter time under these accounts that are tied to the account categories, all hours appear as billable hours within the tempo time report. Any ideas on what is happening? image.pngimage.pngimage.pngimage.png

2 answers

1 vote
Susan Wu
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Apr 29, 2022

Tempo has setup all worked hours as billable by default. For those who only use Billable/non-Billable Accounts at the issue level, this "B" column in the report is not meant for you to use. This is part of the "Set Billable hours" feature for those who actually need to manage billable hours at the worklog level. So when you run Tempo Logged Time reports with Billable Accounts, you only need to show the logged hours. Even if you decided to show this "B" column, it would be the same as logged hours.

As for internal issues, they are the only issues that will have no billable hours by default.

On Cloud, Set billable hours is a project setting. On Server/DC, it's a global setting. For those who use both features, you will have to maintain manually the billable hours on all the worklogs with bulk action on Cloud, or edit each worklog one by one on Server/DC (bulk action is coming soon). 

You can check out our Best practices for tracking billable hours. https://help.tempo.io/cloud/en/tempo-timesheets/organizing-data-using-tempo-accounts/best-practices-for-tracking-billable-hours.html


Also, we have YouTube videos on Billable hours: https://youtu.be/a6BjQ59i70E and on Billable Accounts https://youtu.be/OHfmhnE5714.

Hope this answered your question.

Susan Wu
Tempo Product Expert

Thank you, Susan. "all worked hours as billable by default" is causing a lot of confusion/concern among our executives.

It's clear there are two different approaches.

When a Jira user decides to implement the "Billable Accounts" approach, there should be a way to disable the "Billable Hours" display in reports, since we are not using the Billable Hours field in our worklogs.

Like Germán Isaurralde likes this
Susan Wu
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jan 04, 2023

This is a feature request. There is already a similar idea for On-premise. You can visit Tempo Aha! Idea portal to create an idea for Cloud with your use case for others to vote and comment. Tempo Product team will review them for future improvements. Thanks!

Like Dave Rosenlund likes this

I have the same issue I'm trying to solve!  Any help out there?

Hi, I had the same issue. I think it must be a bug in Tempo...but I solved it by using these functionality - https://help.tempo.io/cloud/en/tempo-timesheets/setting-up-and-configuring-tempo-timesheets/creating-and-configuring-internal-issues.html

Suggest an answer

Log in or Sign up to answer