Jira programatical clone is clonning Time Spent field value

Jose Miguel Garrido May 25, 2020

If you try to clone an issue using *cloneIssueWithAllFields* is clonning the Time Spent cf, but not full worklogs

According to the inteface clone it should not copy any Time Tracking values

Example to reproduce the bug:


def task= issueManager.getIssueObject("FFS-1506")
def subtask = issueManager.getIssueObject("FFS-2851")
def toClone = issueFactory.cloneIssueWithAllFields(subtask)
Issue cloned = issueManager.createIssueObject(adminUser, toClone)
subTaskManager.createSubTaskIssueLink(task, cloned, adminUser)

The original Issue got  2h logged with my workLog



Cloned Issue got the 2h on Time Spent but not worklog


I tried to delete de workLog on the clonned issue using:


But it didnt work,

Do you know any way to reset that Spent Time value after the clone?


Thanks in advice

1 answer

1 accepted

0 votes
Answer accepted
Jose Miguel Garrido June 17, 2020

There is a bug about this funcionality



The way to solved it its adding the line toClone .setTimeSpent(null) just after use the  cloneIssueWithAllFields

def toClone = issueFactory.cloneIssueWithAllFields(subtask)
toClone .setTimeSpent(null); // <<<<<<<< CHANGE HERE >>>>>>>>

Suggest an answer

Log in or Sign up to answer