Jira 7 Setup All User Directories are read only

leonardolb November 30, 2015

I just performed a clean install of JIRA Software 7 but im stuck in first access setup with the following error:

Setup admin account: Cannot create user, all the user directories are read-only



12 answers

18 votes
Philipe_Spouse October 20, 2016

I solved it the same way as Tuncay although I think this is not supported (yet). My install is windows 2012 r2, postgresql 9.6 and JIRA 7.2.3x64. (Also see EDIT below)

It's the same root issue I suspect as https://jira.atlassian.com/browse/CONF-44216

I downloaded the latest JDBC driver from https://jdbc.postgresql.org/download.html (in my case the JDBC42 driver), copied the jar into the lib folder, stopped JIRA, renamed the Atlassian prostgresql jar file to *.bak (not sure if that was necessary?), copied in the JDBC42 driver, started JIRA and it all worked from then, no more error.

I a bit of a noob at these products but it worked, so it seems to be issues with the db drivers used by JIRA and their compatibility with the DB in question. Try updating the relevant drivers.


EDIT: Adding that 1) it IS necessary to remove the old jar jdbc file and that 2) this issue does also occur on Linux and has the same solution. I had the issue with CentOS 7, PSQL 9.6 and JIRA 7.2.4.

Sergey Bartoshik October 21, 2016

Update postgres jdbc driver works for me too.

Manuel Garnier October 22, 2016

Thx Philipe, works for me too

James Watts November 4, 2016

Yep, updating the driver fixed the issue for me, thanks!

popescu_af November 28, 2016

Thanks, it works!

Rodrigo Silva January 4, 2017

Works for me, too!

In addiction to the steps mentioned above, i've had to rename the latest jdbc jar to the default Atlassian postgres jdbc name (in my case, from "postgresql-9.4.1212.jar" to "postgresql-9.1-903.jdbc4-atlassian-hosted.jar")

MacOSX 10.11.6, psql 9.6.1, JIRA 7.3.0


Like Loj Trebla likes this
Deleted user January 10, 2017

Worked on MacOS too! I didn't need to rename the new jdbc.

Vanja Babic April 21, 2017

I've also had to rename the latest jdbc jar to the default Atlassian postgres jdbc name from "postgresql-9.4.1212.jar" to "postgresql-9.1-903.jdbc4-atlassian-hosted".

PostgreSQL 9.6.2, JIRA 7.3.5

1 vote
Bill Spencer October 25, 2018

Just ran into the same problem and tried Chris' solution for MySQL.

Jira v7.12.3
JDBC 8.0.13

Mysql 5.7.23

Switched connectors to JDBC Connector v5.1.47, but that didn't fix it.

Any ideas? ... Should I re-install, and let it rebuild the database?


Bill Spencer October 25, 2018

Re-installed, and it worked!


sanugit0602 November 19, 2018

Hi Bill,
So you used JDBC Connector v5.1.47 and that worked for you
because with JDBC 8.0.13 I'm facing the same issue.
Is that the only workaround for this error?

Chris Levine
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
November 20, 2018

Hi Kumar

Please try using the JDBC connector v5.1.47 as JDBC 8.0.13 is not supported. 

The following guide is helpful. 


In addition, the supported platforms page is helpful if you are new to Jira(Welcome btw!)


1 vote
AmmarJirjees January 25, 2017

Update postgres jdbc driver works for me too.

1 vote
Tuncay Senturk
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
September 20, 2016


I got the same problem with PostgreSql.

I updated postgre jdbc driver to the latest one (9.4) and restarted JIRA

Problem fixed

0 votes
Gregory Kneller
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
February 14, 2023

The cause and resolution are the same as in this KB



Internal directory does not have the all the allowed operations , this could be lost if user updated the database directly.

The below operations should be allowed to Internal directory



Manually insert each operation in the database table cwd_directory_operation for the internal directory

0 votes
kenorb January 18, 2021

The error means your database is not configured property (possibly you've skipped it by opening the /secure/SetupAdminAccount!default.jspa directly). To do that, you need to open the home page first which will trigger the redirect pages which are going to configure your database.

Related: https://community.atlassian.com/t5/Jira-Core-questions/java-lang-RuntimeException-javax-servlet-ServletException-java/qaq-p/1580242

0 votes
marcus December 2, 2018

This happened to me, when restoring a backup of an old version of Jira(7.1.10) to an AWS RDS postgres(9.6 and/or 10.4) database instance.  I was able to resolve this by using an AWS RDS postgres 9.4 instance.  So in my case it was database/application compatibility and deploying the application on an older version of postgres fixed it.

0 votes
Chris Levine
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 25, 2018

Hi Everyone

I recently ran into this problem when setting up Jira with the following settings.

Jira Version - v7.6.9
JDBC connector-8.0.13

Mysql version - 5.7.24

The problem was caused by using the JDBC connector listed above instead of the recommended version which is JDBC version 5.1. 

The following guide has the steps needed and the link to the JDBC version 5.1 that is recommended.



0 votes
nucfisher April 25, 2017

Atlassian says that they are db-agnostic guys. 
Also, they say that Postgres is their favorite DB.
Also, they say that Jira is pure-java app and doesn't care of kind of Linux running on.
Also, one of the most conservative distros - Debian 8 - is already ships with PostgreSQL 9.6 onboard.
As for me - Atlassian just must officially support PG 9.6 for their products.

0 votes
sandeep4774 March 14, 2017

I have solved this issue by removing 'databaseconfig.xml' file from Jira's Home directory and restarting JIRA and setup again.

0 votes
Ryan Manning October 21, 2016

My solution may be limited in scope, but I had to revert to using PostgreSQL version 3 as version 4, when creating a new database, constantly throws the "user directories are read-only." I'm no tech wizard but my problem lied in the tool used to create the database.

0 votes
Pedro Souza
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
November 30, 2015

Hi Leonardo,


Can you please confirm us your database type, and if the user used to connect with the database has the DROP permission? From previous cases, I've seen this same error when the database user was missing this permission

Since you are working in a clean instance, I would suggest you to create a new database for your JIRA instance then give all the database permissions, including the DROP, and try to setup JIRA again with this new database.



Pedro Souza.

Dan Buffham April 3, 2016

I am also having this exact same issue "Cannot add user, all the user directories are read-only."


Why would the db user need drop permissions?

Mike Scott April 21, 2016

Same issue here, user is GRANT ALL PRIVILEGES.

Tuyn Doan April 21, 2016

Same issue here!!! JIRA 7.1.5 (I just instal last version)

I TRY : 

SET GLOBAL storage_engine = 'InnoDB';

GRANT ALL PRIVILEGES ON jira.* TO 'jira'@'localhost' IDENTIFIED BY 'jira@@jira';




==========> ERROR :  (Cannot add user, all the user directories are read-only.)
At page /secure/SetupAdminAccount.jspa

Note : i using root account

Please help me! 



Tuyn Doan April 21, 2016


I install v7.1.4 (not error)!

Cường Nguyễn April 23, 2016

Hi, i'm facing the same problem with brand new download and license from Atlassian.

JIRA 7.1.5 on Windows Server 2008 , MSSQL 2008. The user has DBOwner permission.

Error: Cannot add user, all the user directories are read-only. When creating admin user.

This is emergency if anyone can help I really appreciated! 

Vishal Gamji September 29, 2016

Same issue. Trying to connect to Azure SQL Database (PaaS). Any help is appreciated.

Suggest an answer

Log in or Sign up to answer