In place upgrade from Core 8.5.4 - cannot overwrite files

MikeHalsey July 20, 2020


I am running Jira Core/Software/ServiceDesk on Windows Server 2016.

Had an issue after last upgrade (which installed very smoothly), where the User Management | Directories folder disappeared so I now cannot manage LDAP.  I have read that an upgrade will resolve this.

I have tried to upgrade (twice) from Core 8.5.4 to 8.11.0.. running the installer as Domain Admin and choosing 'Upgrade existing Installation' but it gets part way and says it cannot overwrite several existing .jar files.  Only option I get is to cancel the install, which breaks Jira, so I then have to do a full restore of the server to fix everything!

I also tried a different 'fix' for my issue of replacing the \lib folder with one from a downloaded installer but I couldn't as all the lib folder contents were 'in use' and the original files couldn't be removed.

How do I correctly 'Stop' ALL Jira files from running or being 'used' prior to running my upgrade or 'fix'?  I tried all the documented methods of using 'shutdown.bat' and 'stop-jira.bat' from the ..\bin folder.  I've also tried 'stop service.bat' from ..\jira and also the option in the start menu to 'stop Jira Service' but absolutely none of them release the files...  with the one exception of starting the server in Safe mode! ...but then I can't run the installer.

Surely there must be an easy way to install an upgrade for this software?

All help greatly appreciated.


1 answer

0 votes
Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
July 22, 2020

It is quite likely that you have broken your installation now, when you tried replacing bits of it.  I am not sure that any upgrade is going to work properly if you've now got a mix of old and new.  I would be looking at going back to the backup you took before upgrading.

Files that are "in use" mean exactly that, the files have been read by a process and the process has told the OS it may need to read them again soon.  If you go replacing them while it is active, it could easily go horribly wrong.

So, my two guesses at what might be wrong here (and I suspect it is a combination of both) are

  • You are not stopping Jira before you run the upgrade
  • You are not running Jira and/or the upgrade as the user who is dedicated to running Jira

The first time you do either of these, it is likely that the owner of some of the files that make up Jira gets changed to the wrong user, which gives you problems running it and prevents any upgrade from doing what it needs to

So, I would

  • Stop Jira, and check with the OS that it is completely stopped, don't rely on just running the scripts (as they could be unable to stop it if there are incorrect ownerships)
  • Undo any changes to files you've done manually
  • Check all the file owners are set to the dedicated user for Jira - check both the Jira home directory and the installation directory
  • Start Jira as the dedicated user
  • Check the system information page for "modified files" (There will be at least one, an application properties file, but if there are more, make a note of them, you'll want to check the changes made by an upgrade)
  • Stop Jira and run the upgrade as the user who owns Jira
MikeHalsey July 22, 2020

Hi Nic

I restored my backup so everything is currently running just fine apart from the fact that the UserManagement|Directories option is still missing and I cannot manage LDAP connections.

As mentioned in the OP, the 'documented fix' for this from Atlassian is to replace the lib folder with the one extracted from a downloaded zip of the Core install files.  Another undocumented fix is to upgrade to a newer version.

Before running my upgrade (out of hours), I reboot the server, login as Domain Admin (also the owner of Jira) and then run the scripts to 'stop' Jira... however... it still won't let me rename the lib folder and states all the files are in use.

If I try and do an in-place upgrade, that also fails stating files cannot be overwritten as they are in use.  I'm pretty sure the Installer for 8.11.0 would check everything is stopped prior to running but this doesn't seem to be the case.

Everything you list I have already tried.

Any other ideas would be gratefully welcomed.

MikeHalsey August 18, 2020


Anyone from Atlassian able to help with this???

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events