Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Importing CSV causes error

When user attempts to import a CSV file the following error is displayed:

An error occurred whilst rendering this message. Please contact the administrators, and inform them of this bug. Details: ------- org.apache.velocity.exception.MethodInvocationException: Invocation of method 'getIssueTypes' in class com.atlassian.jira.plugins.importer.imports.csv.web.CsvValueMappingsPage threw exception java.lang.NullPointerException at com.atlassian.jira.plugins.jim-plugin:actions//templates/admin/views/csv/csvValueMappingsPage.vm[line 101, column 51] at org.apache.velocity.runtime.parser.node.ASTIdentifier.execute( at

Any ideas? Thanks.

14 answers

2 votes
Matheus Fernandes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 09, 2018

Hi, @Mark Sanders / @John Di Ciurcio

It looks like you are hitting into a bug in Jira when mapping the Issue Type field during the CSV import: JRACLOUD-68491. As a workaround please try removing the issue type from the mapping option. Alternatively, you can try importing the CSV using the Import to Jira Project option rather than mapping the project in the CSV (this should also work, we'll test this option and update the bug report accordingly if it does).


Is there any way to exclude entries from the import then, when importing to a specific project? To split multi project import is quite laborious.

More than 5 years has passed and I still have this problem

The problem is with the language in the Issues. I had a task Issue Type in two languages and when importing that was the error because it updated from task to tarea (in spanish)

Work on homologating your Issues from your workflows so that they do not have this error or do not select the Issue Type of incident in "Map Field Value"

Hi guys. Try to change the name of the issue type and revert it back. This resolves the issue.

Hi @Tabbish Noorani can you provide more specifics to this workaround?

Still waiting for a resolution

Hi @Yash Doshi. Try to change the name of the issue type and revert it back.

I too have encountered this bug. Still no solution after 2 years?

Affected by this as well.

I am having the same issue, getting an error when I map the issue type field.

Thank you.

Any news on this one? The issue type mapping renderer is still broken

I am having this issue as well. The CSV importer gives a warning if no issue type is given.

I selected the "JIRA Field" (Issue Type to Issue Type) but did not check the "Map Field Value"  I was updating start and due dates.  This worked for me.

Facing the same issue now.  Bug not fixed.

This bug ha not been fixed. Facing the same issue now.

I'm facing the very same issue right now. Did you find a solution?

Suggest an answer

Log in or Sign up to answer