How to hide Epics from Kanban view?

Melvin July 9, 2016

I switched from Scrum to Kanban view and already had some Epics. They're now displayed in the To-Do lane as moveable blocks and don't want Epics to be displayed on the board. The stories are already displaying in which Epic they are by the displayed label and I want to keep that.

How do I hide those Epics from being on my Kanban board?

8 answers

9 votes
Adam R February 8, 2017

What you're looking for is the type field in JQL

To filter out epics: 

project = PROJECTNAME AND type != Epic ORDER BY Rank ASC 

7 votes
Lilianne Riveron August 21, 2020

You can enable the Epics panel in your board configuration. This will allow the epics to be displayed, but not as a card (ticket) on the board.

And in order for this option to show up, you need to enable the Kanban backlog, and this is done by moving a status to the backlog (in the example below, I added "Requirements needed" to the backlog, since I don't need to show those tickets in the board.


Screen Shot 2020-08-21 at 2.32.42 PM.png

Deleted user September 11, 2020

This option, for some reason is not available for our instance of JIRA. Is this something that has to be enabled somewhere else?

Contramonk September 12, 2020

Erick, I was unable to see the option as well. I took an item from the Backlog column and dragged it into the Kanban Backlog. When I did this the button for "Epics Panel" became enabled.

I found the directions here:

1 vote
ALEX DUTHIE April 26, 2021

You can always create a quick filter which basically adds a button to the Kanban view:

  • Go to board settings
  • Go to quick filter
  • In the 'add' row do the following
    • Name the Filter Name
    • Add 'type != Epic' to the JQL field
    • Add a description
    • Add the filter

This should add a button the board like so:

Screenshot 2021-04-26 155455.jpg

david May 20, 2021

This is a good work around to hide Epic on Kanban but have them still viewable in the backlog. Thanks @ALEX DUTHIE 

1 vote
Niranjan May 16, 2019

When i do this by changing the filter , i am not able to see the epics in the backlog too , is there a way to find them

Sarah Tipton June 21, 2019

me too! were you able to find a workaround for this @Niranjan ?

CN February 6, 2020

No - I believe the backlog you are looking at is viewed through the same filter as your board. If you filter out epics in the board, you filter them out of the backlog too.

To the best of my knowledge you need to amend the filter, or create a separate board.

CN February 6, 2020

But I note in our Jira Cloud account, in Board Settings >> Columns there is a toggle as follows:


Epics panel

Display epics in a panel in the backlog, and not as cards on the board


So a way to handle this is don't filter out epics from your board, and then do enable that toggle so your epics are in your sidebar rather than listed in your backlog.

Christian.Terrado April 27, 2020

Is this toggle a feature on a specific version of Jira Cloud? 

youcantgoogleme May 19, 2020

But like this i still need the filter for the Kanban view right? 

1 vote
mavilchis July 6, 2018

The problem of using the Filter (!=Epic) is when you need to base the Swimlanes on Epics, .....

no information ......

0 votes
kryzalid87 May 5, 2017

Had this same problem. Edit filter for board and add issuetype != Epic :) 

Pablo Silva May 25, 2020

You should be able to turn on Epic Panel switch on Board Settings / Columns, that will not only enable Epic Panel on side of Backlog but hide Epics at all on Board view.


Screen Shot 2020-05-25 at 10.18.00 AM.png

Axel Jindra July 3, 2020

Hmm... there is no such switch in my JIRA Cloud? Maybe part of a beta programme?

Like Nick Heath likes this
0 votes
Johnny Hujol February 22, 2017

Great! That's all I wanted to do.

Thx it's been bothering me for a while and this fixed it.

Here is the JQL filter I used

project = <my project> AND ((issuetype = Epic AND status != Done) OR (issuetype != Epic)) ORDER BY Rank ASC

0 votes
Jobin Kuruvilla [Adaptavist]
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 10, 2016

You can modify the board's filter to exclude Epics. What appears on the board is determined by the filter.

Melvin July 10, 2016

Could you be more specific where to find that filter or steps to apply that filter?

Nicolas Bourdages
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 11, 2016

When you go to Boards / Configure, under the General tab, you'll see the filter. Changing and editing the filter is all covered in the doc:

Suggest an answer

Log in or Sign up to answer