Error when using external system import tool to try and update status of sub-tasks

Gngo April 12, 2023

I've been trying to update the status of subtasks linked to a parent but keep receiving this error.

"Unexpected failure occurred. Importer will stop immediately. Data may be in an unstable state: Failed to remove subtasks [OEIT-39] parents. A parent of a subtask cannot be removed."

I've mapped the issue key, issue type, issue ID, parent ID, status, and summary, but keep getting the error saying the importer is trying to remove the subtask parent. Has anyone else run into this issue and worked out a solution? 


I have 806 subtasks to update, so bulk updating within Jira as opposed to via csv import is not ideal.  

2 answers

0 votes
Martyn Beaumont July 12, 2023

Did you find a solution?

0 votes
Trudy Claspill
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 17, 2023

Hello @Gngo 

Welcome to the Atlassian community!

I tried the same thing myself in a Team Managed project and got the same error.

I tried the same thing to change the status of a sub-task in a Company Managed project and it worked.

I'm still looking for any information about why it would not work in a Team Managed project.

Suggest an answer

Log in or Sign up to answer