Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Copy and pasting URL not working in Jira Server issue comment due to text formatting


Running Jira Software 7.13.3

When I'm adding comments to a Jira issue, and I want to link to an external url, I'm always fighting the interface and I'm not sure if this is a bug or if I'm just missing something.


  1. I select some text in my comment that I want to be the link to the external url
  2. Select the external link button.
  3. I will see the following:  [<text I've selected>|]
  4. I replace with the url I wish to go to.  
  5. when I submit the comment,  I still see the exact same [<text I've selected>|<url I pasted in>]
  6. now if I go into edit the comment, and switch over to text mode,  I see an extra set of brackets surrounding the URL, and once I delete out the extra set of brackets and submit, then it works fine.
  7. This seems to have something to do with the content of the URL, because if I leave in the and I hit submit, the link works, but I don't see any special characters or weird formatting in the url I'm using.    In this particular case, I'm just linking to an HP forum post.  

is this a bug? or am I just missing something?  Thanks!

10 answers

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

9 votes
Answer accepted

I think I found the solution to this. 

When you copy and paste(cmd+v) it considers the url as a link. When I pasted it as text(cmd + shift + v), the hyperlink now works

This worked like a charm -- thanks

This worked perfectly! 

THANK YOU! This was just driving me mad.

Wow ,, excellent 
it worked like a rock solid :)

issue continues to exist in 7.13.12

Yes. This might be a bug. I have the same experience. Wondering why no one from Atlassian team answered this question.

Happens here too

just as an update.  issue still exists in 7.13.8

The url detection seems a little flawed still in v8.5.2 when saving.

If I paste the url the interface correctly detects it and allows me to enter a human readable version, however on save it reverts to the Markdown string representation.

Going into text mode doesn't fix it. The url I'm pasting contains a pair of [] (amongst other valid url characters) and therefore it always reverts back to the plain text version regardless of what I do.

The url is from new relic and I've included a version below. To protect privacy the url has purposely been broken.

This issue is not solved as of Jira 8.5.0, part of a company installation which I'm currently using.

As the original post above states, you have to go into text mode, delete the extra brackets around the url, and then submit before the hyperlinked text displays properly in the comment.

Wow.. thanks for sharing the solution @Tim_Menke 

Can't believe this is the workaround I have been looking for and will have to resort to going forward.


Fix Version/s: 4.5.0, 4.4.2


Issue Summary

Sharing a link from "Related knowledgebase articles" panel creates a comment with an incorrectly formatted link. 

Specifically, the hostname is missing which causes the formatting to break.

Did anyone submit a bug report for this yet?

Supposed to be fixed in 8.5, have yet to try it out.

I think that's a different issue... That bug relates specifically to Confluence linking.

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

AUG Leaders

Atlassian Community Events