Cannot edit Label field after JIRA upgrade

Navam Rajput August 14, 2019

After upgrade to JIRA 8.2.4 , the Label Field cannot be edited. Although other fields like components and severity are editable.issue3.PNGissue3.1.PNG

9 answers

2 votes
Ben Robbins August 5, 2020

Just to add in we have also experienced this issue. Luckily we've kept a dev environment on 7.13.5 which has allowed us to troubleshoot any issues we're seeing in 8.6.1.

In 7.13.5 even if the Labels field isn't on the View/Edit screens, it still appears on an issue and has the pencil edit icon next to the field. Clicking this browses to another page where you can add/amend the labels for the issue you were viewing.

In 8.6.1 it looks like this functionality has been removed so there is now the requirement to have the label field on the relevant screens to make it editable.

I can see how this makes it more consistent with the expected functionality but I don't recall seeing this mentioned in any release/upgrade notes provided by Atlassian. It would have been nice to have been prewarned about this rather than us now having to fix forward.

2 votes
Brant Schroeder
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
August 14, 2019


  Is the labels field on the edit screen in the screen schema of that project?  


Brynja Davíðsdóttir October 8, 2019

Is this problem resoveld?

I´m unable to edit the label fields after upgrade to 8.3.4

Jihan October 17, 2019

Same here!!!

Jarno Ahola November 27, 2019

Yep, this is the root cause. For some reason Labels field has been removed from some edit screens during Jira upgrade (7.13.x -> 8.5.x). Anyway, it's still present in all view screens! Also it's present in most of screen schemes, so this affects only some screen schemes.

Why this has happened? And how it's removed from some edit screens, not all?

Fixed this by adding Labels field back to edit screens based on end user complaints.

Like # people like this
Davide_Peveroni December 9, 2019

Same here. 

I have to add Labels field to all screens and now it works.

1 vote
Navam Rajput October 8, 2019

Solution that worked for me : The labels system field is not associated to the respective screen causing the inline editing is disabled in the Edit Issue screen.

Also refer :

0 votes
Stefano Coletta July 10, 2020

Same issue here. But I think I've found the reason. There seems to be in the Atlassian issue tracker and linked issues that seem to speak about this problem. But seems that Atlassian fixed the problem without closing the issues.

Doing a comparison from Jira 7.x with Jira 8.x I've found that in Jira 7.x the labels field was editable because it is always editable; despite if you add the field to the screen or not.

In Jira 7 there was a blue pen there to edit it.


In Jira 8 if you do not put the Labels field in the screen you cannot edit it anymore with this "default functionality" of editing labels provided by Jira 7.

I think they have fixed a problem anyway because in Jira 7 it was possible to edit Labels even if you have not added the Labels field in the screen.

If you have your old Jira 7.x instance still on-line (or a lower version I can imagine) you can verify this by yourself comparing the screens configurations.

All of this means that Jira 8 has not removed, unconfigured or deleted anything during the upgrade: the field was not present on the screen even before the upgrade.

0 votes
Pritesh Jagani June 25, 2020

I had same problem and the way I fixed it was by going into labels configuration and just adding the screens back


  1. Click on the Administration link.
  2. Under the Fields section, click on the Field Configurations link.
  3. Locate the Field Configuration that is associated with the affected project and click on the Configure link under the Operations column.
  4. Locate the Label field and click on Screens.
  5. Tick on the respective screen and the inline editing would be available again.


0 votes
Marina Veselić June 19, 2020


Same here after upgrade from 7.12.1 to 8.4.3. Adding the labels back to edit screens helped.



0 votes
Andrew Moulton April 23, 2020

I haven't even upgraded yet, on 7.13.1.  We are able to edit Labels from the view screen, but it's not on our Edit Screen ;)  I think this is a bug in the older version of JIRA and fixed in the new version.

0 votes
Gaj Umapathy March 12, 2020

I've been having the same issue after the Jira 8.5.3 upgrade. The labels are in the edit screen but still unable to edit via the in-line edit function. 

I can't seem to delete my above comment. In-line edit on labels does work. The user in this case did not have edit permission.

Andrew Moulton September 11, 2020

Add it to the view screen too.

0 votes
DevOps-Tally_ September 29, 2019

did we get any solution. I'm unable to edit the label field as well after upgrade to 8.2.5

Suggest an answer

Log in or Sign up to answer