Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Webhooks not triggering in JIRA OnDemand if the url is HTTPS

Hi All,

     Why Webhooks not triggering the external URL if that is HTTPS? My JIRA server is hosted in Cloud. Is there any settings/Configuration in JIRA to call a HTTPS url in webhooks?

 

Thanks

Esh

 

4 answers

1 accepted

3 votes
Answer accepted
Dave C Atlassian Team Oct 11, 2015

If you're trying to connect to a self-signed certificate, that will fail as the certificate doesn't exist in the Cloud instance's trust store. Cloud only allows connecting to SSL endpoints that have certificates that are signed by a proper CA (ie one that exists in the Java trust store).

You could either get a signed certificate (they're relatively cheap) or would need to look at connecting over HTTP (which is not recommended since the traffic isn't encrypted).

Also it will either need to be running on 443, as other traffic is not allowed through our outbound proxies.

Hi David, We enabled HTTP access in the destination url ONLY for JIRA Cloud instance. Actually we enabled port 80 in the destination server for this IP 104.192.140.178 (https://msi-dev.atlassian.net). Still not working, why?

Dave C Atlassian Team Oct 12, 2015

It would help to raise a support case for this at https://support.atlassian.com and we can have a look further. I went to raise one for you but wasn't 100% on which account to use, and didn't want you to miss the mail.

Hi David, my account email id is Aver.eswaran@gmail.com. Also we are planning to buy SSL Certificate to solve this issue. Are you sure if we buy proper certificate, Webhooks can able to trigger?

Dave C Atlassian Team Oct 16, 2015

I'm not sure if it will or not without looking further, we created a support case for you and can take a look.

Also its self signed certificate in the url

I configured manually. I did not write any addon. If I use HTTP instead HTTPS, its working without any issue. But I want to post only in HTTPS.

I would expect this to "just work". Just to confirm, you have configured this manually? You are not writing an Atlassian Connect addon?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

Send an Email or Publish to Confluence - What should you do with your release notes?

Background When you hear the words ‘Release notes’, almost always you think of an unsolicited email from a software vendor. But I am here to tell you that from our data, sending release notes via E...

124 views 1 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you