Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira sorts and filters due date incorrectly

I have a new install (one month) of Jira core. I have 5 users, 30 issues, one project and a simple workflow. I use English and Swedish.

When I search for issues with overdue due dates it returns issues not overdue (due <= "0").

Clipboard02.jpg

(image from the dashboard with a simple overdue filter. The date was 18th march.)

 

Also, which seems to be related, when I sort by due date, it sorts it incorrectly.

Clipboard03.jpg

Or are there other parameters/factors I have missed?

It should just be a simple date sort, right?

Could there be some wrong with due date storage? I have no clue where to begin debugging.

As you see, the view date is changed from default - but I have also tried default date format.

This post comes from my original post here.

3 answers

I think I have found it.

I had changed the javascript.picker format for incorrectly for a short period of time which made it save the data in an incorrect format for some issues - but not others.

Setting the date/time in look and feel + advanced setting x4 correctly seems to have fixed it. Updating the due date on some issues might be needed.

John Funk Community Leader Mar 23, 2020

Ah! That would probably do it. 

Check you make sure you aren't sorting on another field first. Jira allows sorting on multiple fields. (ie sort on field a, for all issues with the same value a, sort on field b)

0 votes
John Funk Community Leader Mar 22, 2020

Hi Rikard,

Maybe try Due <= now()

Unfortunately that did not help. Is there some know issue with the default way Jira queries overdue dates? 

John Funk Community Leader Mar 23, 2020

Maybe try the field duedate:

duedate <= now() and project = ABC

No difference - tried "project = FS AND duedate <= now()"

I suspect there is something with date format in the system. Don't know how to proceed though.

John Funk Community Leader Mar 23, 2020

Maybe do a re-index since you are on server? If that doesn't fix it then I would open a support ticket with Atlassian. 

I have already re-indexed. Unfortunately we only have a starter license and there seem to be no way to get support for this issue.

John Funk Community Leader Mar 23, 2020

Maybe try hardcoding the date just to see if that works.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

🍻🍂Apptoberfest Update: Upcoming Virtual Events 🎉

Hello Community! I hope you've been enjoying the 🍂Apptoberfestivities🍂 (I know I have!) The event is heating up next week with a series of virtual events that we're calling the 🍻🍂Partner App ...

65 views 0 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you