Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can you add a hyperlink to JIRA

Can you add a hyperlink to JIRA description and/or comment area?

If so how do you do it correctly.

Thanks

10 answers

1 accepted

3 votes
Answer accepted

Yes you. Both of the JIRA system fields you mention above uses the JIRA Wiki Renderer which has many fun formatting you can choose from! Take a read below.

https://jira.atlassian.com/secure/WikiRendererHelpAction.jspa?section=all

In the "LINKS" section, you will have to use:

[http://jira.atlassian.com]
[Atlassian|http://atlassian.com]

thank you!!!

When I try to send a link like as suggested for the 'description, field while creating a JIRA ticket through a R script,

library(httr)

x <- list(fields = list(project = c(key = "TEST"),
summary = "New Issue Ticket Created",
description = "[Issue Doc|http://sharepointsite.com/folder/filname.ext]",
issuetype = c(name = "Task"),
assignee = c(name = assigneeUsrName)
)
)

response <- POST("https://somecompany.atlassian.net/rest/api/2/issue/",
body = RJSONIO::toJSON(x), authenticate("usrName","pwd", "basic"),
add_headers("Content-Type" = "application/json"), verbose())

I only see the text in the description field instead of a hyperlink.

[Issue Doc|http://sharepointsite.com/folder/filname.ext]

What am I missing here?

Like # people like this

Same issue, if I put custom links and not web links, it only displays a text.

Like # people like this

Same here. There must be some limitation to the external link feature. If I use the "Atlassian" example, it works fine. But if I have a slightly more complicated link, it does not.

Like NhojEntuna likes this

Same here. Back then when we were using sharepoint, the link was ok and worked fine but when we changed the server from sharepoint to another one, it doesn't work anymore.

Not working in any browser...any suggestion?

In my case in jira 8.5.5 <a href="url">link text</a> worked.

I mistakenly updated Description in Custom field - Edit (field) whereas it must be done on Field Configuration level since current custom field have been already created some time ago and was used by several projects.

I have found if the link is really long, it doesn't seem to work, so i go to tinyurl.com and get a shorter URL and I've tried multiple time, and it has worked every time. 

 

For example:

[link title|https://tinyurl.com/y6qgdnfm]

Seeing the same here in 7.13.  Is this a newish bug?  It seems like it used to work.  And is it fixed in some 8.X?

I use Chrome and have the issue.

If it's not working click on the 'Text' (not visual) tab under the textbox and ensure that the format is correct. You will probably see this

[text|[hyperlink.com]]

fix it to fit this format:

[text|hyperlink.com]

 Then it should work. 

If your text is as short as "text" and your link is as short as "hyperlink.com", it will probably work.  For cases with longer text and longer links (especially if either or both wrap). . .see the comments above.

Like # people like this

This was the issue for me... it should not appear this way in visual mode so it is still a bug that needs to be fixed.

@Richard Navarro I inspected the text and seems to show correctly as:

[text|hyperlink.com]

Could you please elaborate on how to get to the "Text" tab under the textbox? I am not seeing that in Jira ticket.

I have tried both via API and direct on UI to add a link as suggested:

[Atlassian|http://atlassian.com]

but it never works in any browser. I have tried 2 different recent Jira versions.

What am I missing?

We're running 8.7.1 now and still seeing the problem, but I've found that I can work around it by switching back and forth between Visual and Text.  Sometimes just switching back and forth once is enough to get it to take.  Sometimes, when I'm in Text mode, I add and then delete [s or ]s to the beginning or end of the link and this seems to get its attention.  In 8.7.1 I have always been able to eventually create a working link, after some amount of fussing around.

My current standard trick, if the link does display correctly in Visual mode, is to go to Text mode, type [] in front of the opening [ of the link, then delete [], then check it again in Visual mode.  The seems to have worked that last few times that I've had trouble with a link.

I know this approach sounds goofy and unscientific, but it works for me.  I suspect that there's some little JavaScript state machine connected with the text input control, that the state machine gets wedged under certain circumstances and that typing and deleting extra []s somehow gets it back into the correct state.

@Richard Navarro Thanks, that workaround works. 

But @Atlassainadmin - I mean, really?

This still doesn't work on Chrome. As the webpage loads I see a hyperlink but the moment it renders it returns to text i.e [text|hyperlink.com]

click on the 'Text' (not visual) tab under the textbox and ensure that the format is correct. You will probably see this

[text|[hyperlink.com]]

fix it to fit this format:

[text|hyperlink.com]

 Then it should work. 

Hi,

 

Is this really solved? in which version? I cannot see it working in our instance.


Thanks,

I am having the same issues. Most likely related to this: https://jira.atlassian.com/browse/JRACLOUD-72071

We need this fixed. My issues are coming from when we have a '%20' in the url.

The problem occurs in IE. Create the links in Chrome and everything works fine.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Admins, notify your Jira instance of system-wide changes with the new admin announcement banner

Hi All! We’re excited to share the launch of an announcement banner that lets Jira site administrators communicate directly to their users across their  Jira Cloud instance.  ...

504 views 16 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you