Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Components missing from list when creating filter

שיר בירנבאום August 9, 2018

Hey all,

 

I'm attempting to create a filter that would show Epics (which in our Jira instance is used as the basic issue type for any task except bugs) from a specific project with specific components. I'm also looking for active Epics.

I've set up a JQL:

project = SP AND issuetype = Epic AND status != Archived AND status != Backlog AND status != closed AND status != done AND component = 

When I begin typing a component name it  provides a list of auto completed suggestions, however, this list is incomplete (does not contain all the components in our Jira instance. If I attempt to write the component manually the JQL fails.

Any ideas on why components are missing (while other are present).

Thanks

4 comments

Comment

Log in or Sign up to comment
Hernan Montes
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 9, 2018

Hi and welcome to the Atlassian community,

This is most likely to be that you haven't used the component in any issues yet, when the component does not have any issues it will not appear in search since there's nothing to search for, this is like screen view, when you create an issue and certain fields or custom fields do not have any value, they will not appear in the screen until a value is added.

Create an issue with the component and you will see the component appear in the JQL search.

TIP: You can add values inside a "not in" statement to keep your filter clean and short:

project = SP AND issuetype = Epic AND status not in (Archived, Backlog, closed, done) AND component =

Hope this helps! 

שיר בירנבאום August 11, 2018

Hey and thanks for the reply.

 

The component has been used many times in many issues.

I have managed to make the JQL work by inserting the missing component manually with " ".

Other than that, it just seems to be a bug.

Thanks for the tip!

Ignacio Pulgar
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 14, 2018

If you start building your query through the Basic Search, then Components are most likely been limited to the ones that exist in the previously selected project.

Please, mind that searching for a specific project and a component that had not been previously set on said project will never return any issues, as an issue cannot belong to a component that does not exist in the project it belongs to.

S_ F_ - USA
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 5, 2021

We see same as initial reporter, (using Chrome) in Test Execution search, from Basic specify project name and search and then MORE and component and we get the first 15 of about 37 components defined for the project; entering in the required component name here (it is 24th in the list of components) comes up empty and does not accept input but reverts back to ALL. We can then switch to advanced search and enter in: and component = "Receiving" and search finds them. (tried on other browsers, Firefox/edge, only those were worse).

TAGS
AUG Leaders

Atlassian Community Events