Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Connecting JIRA applications to MySQL Database on Ubuntu 16.04.

holoadmin
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 14, 2018

Hi,

ofcourse possible that I did something wrong but:

This page https://confluence.atlassian.com/adminjiraserver073/connecting-jira-applications-to-mysql-861253043.html explains step by step how to configure and connect MySQL for JIRA.

But it wasn't complete and I probably can prevent others from having the same trouble:

 

For getting JIRA to correctly startup instead of giving me a white error page I had to additionally do the following steps:

  • at 1. Create and configure the MySQL database:
    - 1. add the user directly
    CREATE USER '<username>'@'<host>' IDENTIFIED BY "<pasword>";

    - 2. add the jiradb as in the manual

    - 2b. What is not mentioned: additionally there is a second database required for the schema!!
    After running the config.sh fand setting it to MySQL I noticed that in the `catalina.out` JIRA still asumed this would be "PUBLIC" so I called mine "public" - it fails later if you keep PUBLIC in capitals
    CREATE DATABASE public CHARACTER SET utf8 COLLATE utf8_bin;

    - 3. here you can skip the "IDENTIFIED BY" now since we already added the user in 1. But you have to grant the permissions for both databases! (I just granted ALL to make it simple)
    GRANT ALL PRIVILEGES ON <jiradb>.* TO '<username>'@'<host>';
    GRANT ALL PRIVILEGES ON public.* TO '<username>'@'<host>';
    FLUSH PRIVILEGES;
  • Go on with the rest of the manual. But then after finishing in the <jiraDataFolder( e.g. /var/...)>/dbconfig.xml you will still notice the line
    <schema-name>PUBLIC</schema-name>
    and actually the catalina log complains that this name is only allowed for the H2 database type in non-productive mode (so it would not help to add the database with the name PUBLIC in capitals).
    So all you have todo for finally get it running is to change it to
    <schema-name>public</schema-name>
    or whatever you called the second database and restart JIRA e.g.
    sudo service jira restart

This finally worked for me and I could re-import our old (backup) database data into the new mysql setup.

0 comments

Comment

Log in or Sign up to comment
TAGS
AUG Leaders

Atlassian Community Events