Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to Schedule Auto refresh in Google Sheets

Hello Team,


I have tried to pull the Issues to Google Sheets using JQL and scheduled to pull the data every 4 hours. It worked fine without any issues. 

After a day I am unable to get the Auto Schedule to work. I am getting an error that "

Something went wrong!"

Multiple Google accounts?Google Sheets add-ons may encounter unexpected errors if you are using multiple Google accounts. Please try again while only logged into Google Sheets with the account used to install this add-on.


I do not have any other google accounts set in my computer but unable to resolve this error. Tried Uninstalling the addon and re-installed still no go.

I would really need this to be fixed to run reports for ease of use.

2 answers

2 accepted

1 vote
Answer accepted

Hi all,

Same problem occurs on my instance and I was able to narrow the issue further down: It only appears after you switch in the Schedule to "Hourly".

I was able to setup a new GSheet, connected it with Jira and setup a daily schedule. After opening again the Schedule tab and changing it to "Hourly" the known error message appeared immediately in the new GSheet.

Based on that observation I would assume it's maybe an issue in Jira. 


Do you suggest any workaround for this issue? Or any ETA on the Fix?

Hello @Shyam Sunder Reddy Gade and @Patrick Tabelander 

Just as mentioned by @Earl McCutcheon, we identified that this error is caused by a global issue that is currently affecting several customers using Google sheets.

We received an update about an hour ago from our internal support team that the problem was properly addressed and the fix is currently being deployed to the Atlassian Cloud sites.

That being said, can you please confirm if you're still facing this error today? 

Best Regards,


Like Earl McCutcheon likes this

Thanks @Petter Gonçalves and @Earl McCutcheon for the fast fix - everything is working now again! Great job!

Like Earl McCutcheon likes this

Thanks for confirming,  You guys Rock 👍

1 vote
Answer accepted

Hello @Shyam Sunder Reddy Gade ,

My unconfirmed guess here is that something changed google side recently relating to user sessions being refreshed in mass as you are not the only one to experience this error recently.  However I am unable to find anything in Google support noting any changes were applied and could be related to a security update in the background that has not been made public.

Check out the following thread where I discussed this error with another user yesterday:

But ultimately this is a known conflict in multiple user session with Google sheets, and the recommendations to get around the error as noted on the other thread is to either:

  1. The First option is to only be logged into the (whole) browser with just the google account that was used to authorize the add-on 
  2. The second option if you do need to be logged in with multiple accounts is to log out of all accounts, then log into the browser with the Google account used to authorize the add-on first then log in with other google accounts.  What this option does is set the default account to the first one you logged in with and if that is the same as the one used when installing the add-on, it should work as intended.

Let me know how it goes, or if you still see the error afterwards so we can take a closer look.


This is still an issue i have tried all the option that you have provided. In fact i have removed the add on and re-installed still no go.




Hello @Shyam Sunder Reddy Gade ,

I just updated the other thread as well, but I am reiterating the info here too to make sure you see it,  Our Dev team dug into this error a bit further with me and it looks like this was a deprecated API on google sheets that caused a communications issue between Jira and Google. 

I just got word from the dev team and we pushed out v2.3.3 of the google sheets add-on to production that removes the deprecated API check and you should be good to go.

If any error persists uninstall / re-install google sheets to get the latest version and let me know if you are still seeing any additional errors so we can take get you in touch with our support team to take a closer look at your environment to verify this is the same cause.


Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,407 views 7 29
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you