Setting A Public Space Landing Page (Confluence Cloud)

AB September 19, 2018

We have a Confluence Cloud instance. The instance itself is private. However, we needed ONE page to be accessible for anonymous users. According to Confluence Cloud documentation, the only way to do that (without setting up user permissions and logins) is to create a SEPARATE SPACE > Set it for 'Anonymous' (public) access. Which we did. 

But what is happening is: anytime an anonymous user accesses, the DEFAULT HOME page icon at the top left (in every Confluence Cloud instance) is displaying the 'Activity' page of the PUBLIC space set. 

So in other words, if you go to the Anonymous / Public page, and happen to click the icon in the top left (default home) which is something most people would probably do, what you get is not the page itself, but the 'Activity' feed of the page. And we want to avoid that. 

Here's a screenshot showing the home icon I'm referring to and the 'Activity' and 'Popular' links at top:  


Is there a way around this? In searching the community forums, the only solution I have found posted (that works) involved purchasing a 3rd party tool. This one > "Instant Websites For Confluence" (these run off Aws via 3rd party). 

This 3rd party tool basically republishes a space in your Confluence instance (separately) for public consumption. 

Is there a better option? Or a way to specify that default "Confluence Home" icon at top? It's problematic for us because we have mostly non-technical users that would find this confusing.... 

Thanks for any support/help/suggests.... 

1 answer

0 votes
Shawn C
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
September 20, 2018

Hi AB, 

One option would be to specify a Custom Site Homepage that'll be used when your Users click on the Home Button, they'll be taken to the Space of your choosing.  Please note that this will impact all Users and not just the anonymous ones.


AB September 21, 2018

Hi - that's the problem. We already have this but apparently when a space in your Cloud instance is set as PUBLIC that does not work. Because that landing page itself would apply to the site for being 'private'....

Any other ideas? 

Like wags likes this
Dheeraj Gupta June 26, 2019

Hi @Shawn C ,

We too have the same issue. Nothing is working for us. Even the option you mentioned is not working?

Do you have a better suggestion on this?


Hi @AB , 

Did you find any solution for this problem?

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events