PDF attachments no longer show a thumbnail of the first page - just a grey box

Daniel Barringer
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 7, 2019

If I use the old editor I get a nice thumbnail preview of the first page of the PDF as shown on right

If I use the new editor I get a grey box showing the title and size as shown on left.

 

I prefer the thumbnail image over the grey box.  Hoping the new editor has this feature and I just don't know how to do it yet.

confluence-horz.jpg

 

4 answers

1 vote
alexander.minin January 6, 2020

We are also extremely lacking this function in the new cloud editing experience, along with the ability to drag-n-drop and resize the attachments. 

Are there plans to restore this functionality for the new editing experience?

1 vote
Thomas Øhrbom November 8, 2019

I agree that this is very annoying. With the new editor we also lost the ability to choose to display the thumbnail image in different sizes, and to me the most important option we've lost -> just display the attachment as a link (see here and here for logged issues)! Now we're stuck with ugly grey boxes no matter what.

Another side effect is that we can no longer add attachments in lists (bulleted or numbered); see issue here.

0 votes
alexander.minin January 7, 2020

My current findings which could hopefully helpful workaround for all who's missing some function in "new editing experience':

if you were using old confluence with old experience and then migrated your spaces and pages to the new one, all migrated pages remain under the "old experience"! Moreover, if you'd then clone your migrated pages in your new confluence, those clones will also be with old experience :) 

of you need more details, just shout

0 votes
Dara November 8, 2019

I believe this is the same issue as raised here, right? In any case, it is a known bug that the attachment thumbnails are not displaying on the page itself. There is a ticket running for this. I would suggest adding your vote ;).

There have been some bugs in transferring to the new editor, this is probably just be one of those unintended side effects. I do suspect the priority of changing this will be relatively low, due to the aforementioned bugs they're dealing with.

Also, for further info: Atlassian has a full list of differences between the two editors here, including links to tickets that have been raised over these issues.

Sorry I can't help you solve it, but I hope this helps information-wise!

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events