Jira macros in Confluence do not auto adjust height

Kevin_Draggoo October 8, 2019

I've tried this with the "Created vs Resolved" macro and the "Jira Roadmap" macro. I have not performed extensive testing, but it seems when I first add the macro, the height adjusts fine. After I edit the macro, though, the height of the widget is set to a static, smaller value. 

I've tried editing various fields for the macro, changing the width as both pixels and percentages. Moving the macro around to different areas of the page. Moving the macro into columns. And other random things. 

I'm using Safari on MacOS. This happened before and after I updated MacOS to Catalina. 

I just tried it using Chrome on the same Mac. I used the same page where 2 macros of the same type were both too short. Editing the first gadget made the height correct. Editing the second gadget had no change and was still short.


I tempted fate and edited the first macro again. It stayed the same, correct height. 

1 answer

1 accepted

0 votes
Answer accepted
Angélica Luz
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 22, 2019

Hi Kevin,

Thank you for reaching out to Atlassian Community!

I tested here using the new editor and using the macros for Jira Roadmap and Created vs Resolved and it works normally.

The Jira Roadmap doesn’t have the option to adjust the width and height and the Created vs Resolved has only “width”.

Can you please send us a screenshot of how it looks like when you first add the macro and then how it looks when you edit it?

Is it happening on the new editor or the legacy editor?


Kevin_Draggoo October 22, 2019

Actually, it just happened during the initial chart insert with a different chart. Here are screenshots before publishing the page. I first tried to insert it outside the grid, then I moved it into the grid. (See screenshots.) Same result. I also added screenshots of the widget settings and preview.


My URL shows "edit-v2" so I assume it's the new editor. Screen Shot 2019-10-22 at 3.29.19 PM.png


Screen Shot 2019-10-22 at 3.29.40 PM.png

Screen Shot 2019-10-22 at 3.30.28 PM.pngScreen Shot 2019-10-22 at 3.30.13 PM.png

Kevin_Draggoo October 22, 2019

Now I created the same Average Age Chart outside of the grid using the "/" insert command. Then I published the page. Now, that widget is too tall and my Created vs. Resolved is cut off.


Screen Shot 2019-10-22 at 3.46.59 PM.png 

Kevin_Draggoo October 22, 2019

To make it more fun, I previewed an earlier version. The graphs look fine, even if the formatting of the text around it is misplaced. 

Screen Shot 2019-10-22 at 3.50.44 PM.png

Like Dave Freund likes this
Angélica Luz
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 24, 2019

Thank you for the screenshots and details, Kevin.

I was able to replicate the issue on my test site. When I first add the gadget it shows correctly but then adding a layout or just the process of publishing and editing again, the gadget breaks.

This issue was reported as a bug and I added more screenshots and the link to this question:

Please, click on "This affects my team" and watch to receive updates about the bug.

Like # people like this
Kevin_Draggoo October 24, 2019

Thank you!

Like Angélica Luz likes this
bpohuski January 27, 2020

I am experiencing the same issue and has effectively made charts in Confluence useless unfortunately. Automated reporting all on one ecosystem was one of the big reasons why the team moved to Jira & Confluence. I've voted on the issue raised.

Like # people like this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events