Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

How to copy and paste entire table in Confluence 4.1

Editor improvements Copy and paste table improvements You can now copy and paste multiple table rows and entire tables. There are also new keyboard shortcuts. You can now use Alt+Up Arrow or Alt+Down Arrow to add a row above or below the current row.

This is listed as a new feature of 4.1 however I am unable to locate the functionality of this. Has it been implemented?

11 answers

1 accepted

29 votes
Answer accepted

Thanks @njinji. The quickest for me was similar:

  • 1 : Create single cell table
  • 2 : Unformat header (remove header row)
  • 3 : Select all rows in source table
  • 4 : Copy rows (CTRL SHIFT C)
  • 5 : Place cursor in destination table
  • 6 : Paste rows (CTRL SHIFT V)
  • 7 : Delete last empty row in destination table

Perfectly done! This worked exactly as stated.

Like # people like this

Another similar technique would be to:

  1. Select text from above & below the table you wish to copy
  2. Paste into the destination.
  3. Delete excess text above/below the pasted table in destination.

To me this was simpler, especially since unfortunately the technique mentioned by @Arithzari didn't work for me.

Like # people like this

Thank you very much @Patrick Nelson. Your solution worked great!

Like Patrick Nelson likes this

Thank You. This works well.  Saves time.

@Patrick Nelson - A bunch of thanks. Day saved.

My Company uses Macs. The command key isn't doing this correctly. 

Like Ramita Rajaa K likes this

Command key works fine for me, using macOS High Sierra.

Thanks for the hint on removal of header row, that's worth gold!


Wow, it was so simple! Thanks @Patrick Nelson!!!

Like Patrick Nelson likes this

Another Thank You to Patrick Nelson.  This technique worked beautifully!

Thanks @Patrick Nelson! Your solution was simple and it works!

Like Patrick Nelson likes this

Hey @pnelsonsr, my one has tables only. So I added testing words before and after the table and give it a go. This is magic. Thanks.

Like Patrick Nelson likes this

I can't believe this is still an issue in 2019... c'mon Atlassian.. Let's get out of the 90's!!!!!!   #FeatureRequest

Like # people like this

It's 6 years later, and no reasonable feedback or change has been made.

Today marks the threshold : I'm starting the process of breaking away from Atlassian and moving to a better tool.

Like # people like this

How I feel coming back a few years later, realizing how many people I had helped 😄


Like # people like this

Thanks Patrick Nelson , it helped !!!

Like Patrick Nelson likes this

This man deserves a beer, Helped me 30seconds ago

Like # people like this

And still going thanks for the tip.

Your software is crap. Previously: I can create tables with || for the headers and | for the table elements. Now: well, nothing you've touched with your awful editor works right and I'm searching help for HOW TO PASTE A BLOODY TABLE. I'm also begging the cto to stop sending you people money.

Mmm, well, much as I also dislike some things about the new editor, there's no need to be quite so aggressive. If you ask for help nicely, you might get some constructive help. Yelling and being rude gets you ignored or even shut out.

If you really don't get on with the new editor, then you're already doing the right thing in asking your company to switch to another system. I know you're not alone - a lot of my clients have said "we're not moving to v4" and are either waiting to see if there's an adequate fix forthcoming or initiated migrations away from Confluence because of this.

Like # people like this

+1 for Nic's comment.

I agree with @Nic Brough _Adaptavist_However, in the light of a failed process, aggression helps highlight the problem : Atlassian simply does not (or cannot) process constructive feedback. Aggression is simply the next escalation. Atlassian would do well to take note how much 'aggression' on their support forums is based on escalated frustration at the absence of logical and expected functionality.

The hints are not being taken.
The right thing to do is to stop using Atlassian. Talk with you wallet, and talk back in a language that Atalssian will listen to : using superior competition.

Multiple other useful and simple suggestions by myself (other accounts) and other constructive feedback have not been acted on.

Today marks the threshold : I'm starting the process of breaking away from Atlassian and moving to a better tool.

I have to agree with Earl here. Bitbucket is fine, SourceTree is pretty good; Confluence and Jira are some of the worst software I've used in 35 years as an engineer. Confluence is buggy as all get out and Jira is a usability nightmare.

I don't think these improvements affect UI changes in the editor from 4.0 to 4.1. Basically, to copy multiple rows, just highlight table rows, select "Copy Table Row" toolbar button, move the cursor to where you want to paste, and then select "Paste Table Row" button. Alt+Up Arrow or Alt+Down are just keyboard shortcuts. For more information on working with tables, please see:

Hi - can anyone tell me the magic to copy a Confluence table from one "document" to another "document" ? I was trying to copy a table from another "document" in Confluence, but when I paste this into my "new" Confluence "document", It copies the "text" from the table, but not actual table "outline" itself.  I also cannot get the "full table" (text and "outline/structure") to copy into Word.  Again, only the text copies.  Weirdly, however, the "full" table (text and "outline/structure") WILL copy directly into Teams.


Thanks in advance for the help !



Mykenna Cepek Community Leader Jan 11, 2021

It's important to properly select the entire table first. Otherwise the copy-paste operation won't work as expected (copying the table itself - not just the content).

The very top-left corner is used to select the whole table, when editing a Confluence page:


Another possible point of confusion is that Ctrl-C might not be a copy operation for some people. I use Cmd-C on my MacBook Pro. Keys can also be remapped.

So to be sure, you can use your browser menus for "Edit > Copy" and "Edit > Paste" for those operations (to avoid using the keyboard).

Also, be sure to put your cursor where you want the table copy to be inserted. If you don't do this, the new table copy just replaces the existing (selected) table, and doesn't appear to do anything.

I just tested all of this, with empty table and with tables that have content, in our Confluence Cloud instance. It's all working fine for me.

I can say this does not work today, April 2nd 2021.  It had previously worked just fine for me.  I cannot get it to work in chrome, firefox or IE on a mac or windows machine.  It would be nice to be able to copy tables again from one page to another if you need to.

@patrick gassner I find that my table copy & paste results in recent versions of Confluence are inconsistent, but they work far better if I prep a table within the recipient document in advance.

  • Note size of original table in Doc 1
  • Create an identically sized blank table in Doc 2
  • Copy original table from Doc 1
  • Paste copied table into the blank table in Doc 2 
  • Voila!

It's clunky, but when other methods listed above (that sometimes work but sometimes don't) fail, this generally gets the job done for me. Works well from Confluence to Jira, too.

Good luck!

Mykenna Cepek Community Leader Apr 02, 2021

I just retested the directions I posted on Jan 11, 2021 above. They work fine on Jira Cloud, on my MacBook Pro running Big Sur in the latest Chrome, Safari, or Brave browsers.

Like Kit likes this

Just tried your steps again on a two week old macbook pro, latest version of chrome with 0 luck.  Pasting with cmd+c or from edit menu on browser does nothing.  It did not make a difference if I clicked on the upper left cell of the table or if I manually highlighted it all.  

I did have luck with Kit's steps, but would be great if it would work with normal copy and paste commands.  

Like Kit likes this

None of the above worked for me. What I did was I created a blank table with the amount of rows and columns in the column I was trying to paste. I then pasted that into the blank table and it worked. I'm using a macbook. 

I just tried your suggestion on my windows laptop & everything copied into the first column.  So frustrating!!!


Paste your excel table and you will get the characters to paste in jira.


It worked for me. 

Like Patrick Nelson likes this

Hah, it was so random seeing my name referenced down here. Glad my approach helped. 😊 

I tried to copy a table from a Confluence page to an email I was writing (not just link, but copy).
I tried to do it in Linux, and my email client is Thunderbird.
Whenever I selected the table (and the text around it), it did not select the table headers, and the formatting of the pasted table did not look good (I think it did not have border lines).
I tried it both with Firefox and Chrome.
The solution was to go to edit mode in Confluence and there the table did copy correctly (also with the header line), and when pasted to Thunderbird, it looked OK.
Hope this helps.
BTW I use Confluence 6.2.4, but a search for my problem brought me to this page.

Copy your table from Excel into Word, then from Word into Confluence. 
This may not apply to each person's environment, but it's a lot simpler than going through plugins and multi-step processes.

Here is a related bug report:

Suggested work around is to copy from the finished/published version, open the editor and paste it which did not work for me.


What worked for me was to

* Go to edit mode, mark a mixed section with text and table and copy it

* Go the target section and paste

* Manually delete the remaining empty table (very annoying).

This only works once: After paste I am not able to select the next section to copy.

=>Save the current state. Go again to the edit mode. Now you can do the next copy paste operation.



If you are using Table Filter and Charts add-on, you can use a Copy Table button to copy any table to the clipboard in a single click.

Guys, 1. create a new table with the same number of columns (just a header and 1 row is fine) 2. highlight all the rows you want from the old table and click the copy table rows icon 3. click into a cell in the new table and press the paste table rows icon so you see instead of copying the entire table you are pasting all the rows -- same thing!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence Cloud

Presenter Mode for Confluence is here 🖥 👩‍💻

👋  Hello Community!  My name is Stephanie Zhang, and I’m a product manager on the Confluence cloud team. Today, I’m excited to announce the rollout of  Presenter Mode : a ...

38,598 views 56 158
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you