Getting a 401-Unauthorized Error on REST API

Stanislav Vincent May 29, 2019

I am using Confluence Cloud. All worked perfectly but suddenly (max 1 months ago) my REST API call stopped working and it returns me an unauthorized error. I have tried both basic authentication call which I do believe are 100% correct. When I use URL in the browser when I am logged into the Confluence all works fine.

My commands:

1) curl -u s.vincent@gmc.net:PASSWORD -X GET "https://gmcwiki.atlassian.net/wiki/rest/api/content?orderby=history.createdDate%20desc&expand=space,history,metadata.labels&type=page&spaceKey=PKB&limit=100&start=0"

2) curl -X GET -H "Authorization: Basic BASE64TOKEN" -H "Content-Type: application/json" "https://gmcwiki.atlassian.net/wiki/rest/api/content?orderby=history.createdDate%20desc&expand=space,history,metadata.labels&type=page&spaceKey=PKB&limit=100&start=0"

I set up basic authentication based on this article.

Found among the articles that it could be caused my CAPTCHA in case log-in failed more times. First, of I am never asked for CAPTCHA when I am logging in but in Security Configuration is set to 3 and cannot be disabled.

I have tested API call in Postman as well and the result is the same unauthorization error.

Does anyone have any hint? Thanks

1 answer

1 accepted

3 votes
Answer accepted
edwin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
May 29, 2019

Hi @Stanislav Vincent ,

Please take a look at this similar question.

Client must be authenticated to access this resource.

Stanislav Vincent June 4, 2019

Thanks a lot, @edwin . Works perfectly!

Like edwin likes this

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events