Error installing Confluence getting started in Mac - Sqlite3

rpandiaraja March 3, 2018

I am being stuck at installing Confluence getting started plug-in in my mac.

Following are the errors related to sqlite3 & node-gyp. Need help.


node-pre-gyp ERR! Tried to download(403): 

node-pre-gyp ERR! Pre-built binaries not found for sqlite3@3.1.8 and node@9.5.0 (node-v59 ABI) (falling back to source compile with node-gyp) 


7 warnings and 3 errors generated.

make: *** [Release/] Error 1

gyp ERR! build error 

gyp ERR! stack Error: `make` failed with exit code: 2

gyp ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:258:23)

gyp ERR! stack     at ChildProcess.emit (events.js:160:13)

gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:209:12)

gyp ERR! System Darwin 17.3.0

gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "build" "--fallback-to-build" "--module=/Users/<usr>/sample/node_modules/sqlite3/lib/binding/node-v59-darwin-x64/node_sqlite3.node" "--module_name=node_sqlite3" "--module_path=/Users/<usr>/sample/node_modules/sqlite3/lib/binding/node-v59-darwin-x64"

gyp ERR! cwd /Users/<usr>/sample/node_modules/sqlite3

gyp ERR! node -v v9.5.0

gyp ERR! node-gyp -v v3.6.2

gyp ERR! not ok 

node-pre-gyp ERR! build error 

node-pre-gyp ERR! stack Error: Failed to execute '/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/Users/<usr>/sample/node_modules/sqlite3/lib/binding/node-v59-darwin-x64/node_sqlite3.node --module_name=node_sqlite3 --module_path=/Users/<usr>/sample/node_modules/sqlite3/lib/binding/node-v59-darwin-x64' (1)

node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/Users/<usr>/sample/node_modules/node-pre-gyp/lib/util/compile.js:83:29)

node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:160:13)

node-pre-gyp ERR! stack     at maybeClose (internal/child_process.js:943:16)

node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:220:5)

node-pre-gyp ERR! System Darwin 17.3.0

node-pre-gyp ERR! command "/usr/local/bin/node" "/Users/<usr>/sample/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"

node-pre-gyp ERR! cwd /Users/<usr>/sample/node_modules/sqlite3

node-pre-gyp ERR! node -v v9.5.0

node-pre-gyp ERR! node-pre-gyp -v v0.6.31

node-pre-gyp ERR! not ok 

Failed to execute '/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/Users/<usr>/sample/node_modules/sqlite3/lib/binding/node-v59-darwin-x64/node_sqlite3.node --module_name=node_sqlite3 --module_path=/Users/<usr>/sample/node_modules/sqlite3/lib/binding/node-v59-darwin-x64' (1)

npm WARN sqlite3@3.1.8 had bundled packages that do not match the required version(s). They have been replaced with non-bundled versions.



npm ERR! errno 1

npm ERR! sqlite3@3.1.8 install: `node-pre-gyp install --fallback-to-build`

npm ERR! Exit status 1

npm ERR! 

npm ERR! Failed at the sqlite3@3.1.8 install script.

npm ERR! This is probably not a problem with npm. There is likely additional logging output above.


4 answers

0 votes
John D_ Lewis March 28, 2018

Found a workaround. Apparently, Node v9 is the issue. If you downgrade to Node v8, it should work.

0 votes
John D_ Lewis March 27, 2018

I tried the steps posted here:

npm i sqlite3 --build-from-source=sqlite3

Then ran `npm i` again - and it didn't work - same error.

Looks like a problem with ..\src\ error C2664...

0 votes
John D_ Lewis March 27, 2018

I'm getting the same error on a Windows machine

Node v9.9.0; npm v5.8.0

Happened during "npm start"

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events