Cannot edit DrawIO diagram, but can see it

Jeff Rauch
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 13, 2019

This has happened to me on two different occasions, slightly different steps but same outcome. In both cases, the end result is I have a diagram I cannot update.  I can assure you there are no page permissions issues that are causing it as I am the admin for both.

Step 1 (both scenarios): Created a diagram but forgot to change the name before I started working

Step 2 (both scenarios): Completed the diagram and couldn't find a "Save As" option so saved it with the generic name "Untitled Diagram"

Step 3.1 (scenario #1): Decided I wanted the diagram on a different page than the one it was created on, so I removed the diagram from the original page and added to the new page.  I could not edit the diagram from the new page, so I added it back to the original page and still no luck. 

Step 3.2 (scenario #2): Tried to change the name of the diagram from the attachments page.  After doing that I could not update the diagram... so I changed it back, still no luck.  

I need to make changes to both and 'd really prefer to not start from scratch again, any help would be most appreciated. 

1 answer

0 votes
John Almeida June 21, 2019

Hi Jeff,

Step 1 & 2, I don't believe Draw.io has a "Save as", but rather includes a File -> Rename which I think you are referring to in Step 2.

Step 3.1 & 3.2 - I'm assuming you used the "Embed Draw.io diagram" option when you tried to move it to a new page which I am also finding it hard to figure out how to edit.

I did find that by going back to create a new Draw.io diagram in the new page and then in the template library, clicking "Recent", it allowed me to edit my original diagram. See what I am referring to here.

 

I hope this helps! If this doesn't work, you can always switch to Gliffy 😉

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events