Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,039
Community Members
 
Community Events
176
Community Groups

Can I indent a bulleted list more than than the default starting indention?

In Confluence 6 I could indent a list as much as I wanted before the start.  This no longer seems the case in version 7.  It seems to mandate that the list start to the far left, with an initial indent.

I use this a lot and am a bit frustrated.

Anybody else seeing this or have a workaround?

4 answers

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

3 votes
Answer accepted

Hello Jim,

Thanks for testing this issue and bringing it to our attention. I’ve been able to recreate the issue with your provided examples and confirmed the issue is present. With this said, I’ve created a bug request to have this looked into. You may find the bug request at CONFSERVER-58987, we ask you to please vote and watch this request for future updates to its status.

Thanks again for reporting this removed functionality.

Regards,
Stephen Sifers

Thanks for the reply.  It would be great to get this fixed.  It's something I use a lot and I've had to come up with a fairly awkward work around.

Like # people like this

Hello all!

Following up on this post. The bug, CONFSERVER-58987, has been marked as closed with a fix version of 7.7.2.

Regards,
Stephen Sifers

Like Thiago Pallaro likes this

Hi @Stephen Sifers , This Bug is affecting the Cloud version of Confluence (maybe a regression?) Can you please clone the fixed bug, but for Cloud? Thank you

Like # people like this

I'm also hitting a bullet list indentation limit. I guess I'll have to use a different product for my documentation.

Like Andrej Križan likes this

It is annoying but expect they'll fix the cloud version as well.  I've created some work arounds with some custom macros I can share if you are interested.  We have a lot of content in Confluence so are committed to the platform and generally like it.  Everything will have their shortcomings. 

Actually I see I already posted my macro below.  :)

In the cloud version just hit Tab at the beginning of the bullet to indent right (Shift+Tab to indent left).

Like Donovan Jones likes this

@Renato Luis 

Hitting tab at the beginning of the bullet does nothing in my cloud version. Shift+Tab removes the bullet, but Tab will not intent it further than the default one or two character indent.

Like # people like this

Hello,

My question is a little bit different as I wonder how can I indent numbered list and use only numbers and not alphabet (ex: 1 - 1.2 - 1.2.1) 

Thank you in advance,

Gvantsa

I use Section and Column macros for indenting (see my entry above).  While it is not WYSIWYG, and can be a pain to edit (especially when using multiple columns), but it does work.  I set the empty indent column to 15 to 20px per level of indent.  Use whatever looks good to you.

As for the numbering, well, that's a whole different kettle of fish.  There are paid add-ins.  One is Number Headings Pro, but it is for numbering headings not lists.  There is probably one for a word processor style control of numbered lists--but I could not find one.  You may have to either write one yourself or work with one of their partners.  Neither seem like a good solution for a feature that should be standard in an application such as this. 

If your administrator has enabled the HTML macro, you can use HTML to set the <ol> tag to the desired format.  For good reason, our administrator has disabled that macro.

Same problem in version 7.2.2

Any plans from Atlassian to solve bug CONFSERVER-58987? Or is Atlassian only preferring new (also buggy?) features?

Like Rachel Wallace likes this

In this post Payne suggested switching to Text mode & using multiple stars / hashtags to create indented bullet lists.

* Main level item #1
** Indented item #1
** Indented item #2
* Main level item #2

This post from earlier in 2019 asks basically the same question.  

What I came up with is wherever I want the indented bullets is to use a Section macro.  Then in the Section macro put a blank Column macro of the desired width.  I added one more Column macros of default width and added my bulletized list.

This would also work well to add a multiple column bullet list of however many columns you desire.

I started with a two column (wide narrow) default section then embedded the Section and Column macros.

Al,

That is an interesting approach. Thanks for sharing it.  I'll give it a try. 

I created a user macro "Indent panel (variable)" that creates a panel indented with a parameter value and then put the bullet list in there.  There is a slight problem with the line spacing just after the macro but otherwise works well.  I also use it to indent tips and info boxes.  I'm big on using indention for reading clarity.   

## Macro title: Indent Panel
## Macro has a body: Y
##
## Developed by: Jim Heddles
## Date created: 30/May-2019
## Installed by: Jim Heddles

## @Param leftmargin:title=LeftMargin|type=string|desc=left margin|default=60
## @Param units:title=Units|type=string|desc=px or %|default=px

<style>
.notableborder table.confluenceTable, .notableborder table.confluenceTable td, .notableborder table.confluenceTable th {border: 0;}
</style>
<div class="notableborder">
<table style="margin-left: $paramleftmargin$paramunits;">
<tr><td>
$body
</td></tr></table></div>

 

I also have a macro "Hide Table Borders" and could use this with the first column containing a string of characters to achieve the indent and then color them white.

All a bit of a pain when it used to work just fine.

Thank you Jim!  I am trying to use this.

Do I need to put a value in somewhere?  It is not working for me.

It should default to 60px, but you can adjust this with the "Edit" feature of all macros.

indent1.pngindent2.png

Don't forget to se choose "Rendered" in the macro definition.

indent3.png

Thank you!!  You are the best..  works like a charm. 

Looks like section macro is not anymore in the product: https://support.atlassian.com/confluence-cloud/docs/insert-the-section-macro/ and user macro cannot be defined in the cloud version, so not sure if there is a solution for that anymore?

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

TAGS

Atlassian Community Events