Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

User created templates -- issue: content not saved once published


Hi all. I have an issue when creating templates in Confluence (under space settings, content tools, user created templates). I create (under create new template) and populate the page, once formatted I hit save, the template gets created but all the content is gone. Alternative approach, publish template empty, hit edit and populate page to then save ends up with the same result - populated content does not get saved. Any help or guidance would be much appreciated 🙏🏼


AhmadDanial Atlassian Team Nov 27, 2018

Hello, Lukas.

I just tried to reproduce the issue on my end though I verified that the newly created template gets populated accordingly when I chose it from the Create page. For example:

Create a new content:

Screen Shot 2018-11-28 at 08.48.02.png


Template under the Blank Space:

Screen Shot 2018-11-28 at 08.48.13.png

Can you please confirm if you are still observing the same behavior on your end? Additionally, can you please let me know if you are using any specific macros on that page so I can try to reproduce it specific to the scenario you have on your side? 

Thanks for your reply, Ahmad.

Whether I simply type in content or copy and paste content from another confluence page, the result remains the same: once saved, the content I created disappears..

AhmadDanial Atlassian Team Nov 27, 2018

Hi, Lukas.

You are welcome. That's an unexpected behavior. Can you please provide some screen shot(s) from your end so I can verify the steps you reproduce it on your end?

the content I created disappears

Does that mean the template was created but the content is empty or is the template is not even created in the first place? Is there any error that appears on the interface that you can share?

Just want to understand the problem as much as I can to see if you might be affected by any of the Confluence Cloud bugs below:

Please keep me posted. Thanks.

Yes, template was created but content is empty. When editing the published "empty" template and hit save, it remains empty. No error message showing on interface, nothing I can share. Other colleague in my team has the same issue, we both have full admin rights. Any opportunity to take conversation offline with Atlassian?

AhmadDanial Atlassian Team Dec 03, 2018

Hi, Lukas.

Sure thing. I went ahead and created a support ticket on your behalf to the Atlassian Cloud team for further assistance on this matter. They will be in touch with you soon. Thanks.

Like Lukas Stuckel likes this

I work for a hugggge bank and I have a deadline tomorrow. I have tried 6 times to create a template and when I click "Save" it is available in the Create.... but doesn't have any of the formatting of anything!!


Please help.

Ditto for me. And in fact, I made the mistake of doing lots of work before I clicked Save. I'm in a very foul, anti-Confluence mood at the moment. 

Anybody discovered anything yet? Ping! Ping! Ping!


Log in or Sign up to comment
Community showcase
Published in Confluence

You’re invited: Confluence for MS Teams Live demo + Q&A

This past summer, we joined forces with Microsoft Teams as a part of our mission to help your team collaborate better, starting with more effective meetings. We released a new and improved Confluence...

60 views 0 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you