Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,262,308
Community Members
 
Community Events
164
Community Groups

Password not working on SourceTree

Ok I'm having trouble cloning a project on my Bitbucket.

I have SourceTree installed and when I clone a project using Bitbucket site I get a authentication log in.

I used my username and password (i'm pretty sure i used the correct one since i tried it on the bitbucket site and it worked) but sadly it doesn't accept and just sends me a Authentication failed error.

Here's the image

http://www.2shared.com/photo/FmKqnu0c/dsadasdsadsa.html

37 answers

1 accepted

7 votes
Answer accepted
minnsey Atlassian Team Nov 30, 2015

Please see https://jira.atlassian.com/browse/SRCTREEWIN-3944 for updates and a work around. A new release will be coming tomorrow morning San Francisco time.

I just installed the latest ST update 1.6.24.0 for Windows, and now am getting Authentication Failed across multiple different Bitbucket accounts. Team members who are still on 1.6.23 are fine, all who have upgraded to 1.6.24 are failing auth.

I'm having the same issue on Windows 10, just updated to 1.6.24.0.

I just uninstalled 1.6.24 and reinstalled 1.6.23 and that version works fine (good news is uninstall and reinstall doesn't lose your repo configs). The problem with 1.6.24 is it loses all your accounts under Tools -> Options - Authentication tab. http://downloads.atlassian.com/software/sourcetree/windows/SourceTreeSetup_1.6.23.exe

Same issue for me. Updated to 1.6.24 this morning and could not commit anything, though I could browse the repos I have. Downgraded to 1.6.23 and all is well. Thanks for the link!

Same issue on 1.6.24, Windows 10.

After downgrade to 1.6.23 and look into Authentication tab again and found that in the new version 1.6.24, the host changed from (bitbucket.org in 1.6.23) to (http://www.bitbucket.org in 1.6.24), maybe it aroused the authenication problem

Thanks for the link to download the previous version. I ran into the same issue with authenticating to BeanstalkApp repositories

I also have the same issue on 1.6.24, Win 7

I've ran into the same issue. I've submitted a bug. https://jira.atlassian.com/browse/SRCTREEWIN-3948

Same for me: 1.6.24 - can't authenticate with correct credentials; 1.6.23 - works fine.

Same issue on 1.6.24, Windows 10.

minnsey Atlassian Team Nov 30, 2015

Hi, yes we've seen this reported a number of times and are currently investigating. Apologies for the problems.

minnsey Atlassian Team Nov 30, 2015

Also can I just check, my testing so for indicates using SSH for git interactions works correctly the problem is with HTTP/HTTPS. Does that sound correct?

+1, https login from 1.6.24, Windows 10 is dead

Deleted user Nov 30, 2015

Yes HTTPS login does not work fatal: Authentication failed for 'https://';

Like cariasbotella likes this

Thank you for the link to download previous version (1.6.23) that worked for me

minnsey Atlassian Team Nov 30, 2015

Please see https://jira.atlassian.com/browse/SRCTREEWIN-3944 for further updates.

I just updated to 1.6.24.0 and also experiencing the same problem on Win10 Wasn't an issue prior to the update

Haven't they released an update to fix din? I do not want to uninstall and install again. I'm worried about all the preferences and settings too. Please release a fix on this asap.

@Carmela Umali i unistalled and then installed v1.6.22 and all my preferences are the same

The Askpass.exe.config fix worked for me. I just added it in C:\Program Files (x86)\Atlassian\SourceTree

Deleted user Dec 01, 2015

The rolling back to 1.6.23 worked for me. Advised our team to avoid 1.6.24 Cheers J

Askpass.exe.config fix worked for me as well. The fix can be found in the above JIRA ticket posted by Michael Minns.

same issue, shame on you, atlassian.

Askpass.exe worked for us as well. Will work until tomorrow's fix.

I am also with this problem. Only solved making the downgrade!

The Askpass.exe.config from https://jira.atlassian.com/browse/SRCTREEWIN-3944 worked here as well.

Thanks Murray, the rollback worked for me!

There's a new update. I was with this problem too, but now with the new update it's fine.

I am having the same problem, but against an internal TFS server using windows authentication. Sourcetree keeps prompting me for my username and password despite working for a while, and I think it has caused my account to lock out the past two days. It was working fine until I changed my domain password last Friday...since then Sourcetree seems to lose my new password periodically. I'm reverting to 1.6.23 to see if that fixes these problems.

Same issue for me. Updated to 1.6.24 this morning and could not commit anything, though I could browse bandarq the repos I have. Downgraded to 1.6.23 and all is well. Thanks for the link!

I encountered an error like this while trying to register the software (e.g. to avoid free trial time limits), and it was driving me crazy. Eventually I discovered that the username and password I was entering were for BitBucket but the client wanted my Atlassian ID. Why these are not the same is a mystery to me, but why the client did not make it clear which credentials I should be entering is a design flaw.

Same issue for me. Updated to 1.6.24 this morning and could not commit anything, though I could browse http://mdomino99.com the repos I have. Downgraded to 1.6.23 and all is well. Thanks for the link!

They already fixed it. Do a "Check for updates" in the app to upgrade to 1.6.25.

Ref: https://jira.atlassian.com/browse/SRCTREEWIN-3957

Following a new install of Sourcetree 2.7 on a Mac the initial login succeeded but on the first access to remote repositories required another login which repeatedly failed using correct credentials. This was  solved as follows:

In sourcetree navigate to preferrences -> accounts.

Select the account listed and change the login type to OAuth - login form presented and credentials were accepted.

Remote repositories listed correctly.

Explanation (?)

On the initial login the licence file was downloaded from Atlassian completing the account details that had existed in a previous version - this used the username / password - authentication now uses email not password - by changing it to OAuth I was able to enter the new style email / password and reset the app.

I tried this and for a brief second i see my avatar when the edit screen is open, as soon as i confirm it it goes blanc again

i see this error

'Could not authorize request with the available token. Please re-authenticate.'

Im new to this forum, tried adding a second note here and keeps beeing deleted some how???

 

Found a stack exchange post.  using this worked for me using ssh, using the beta version

ssh://git@github.com/USERNAME/REPONAME.git

 

Seems like the input is wrong when the app is used and account is setup?

Im new to this forum, tried adding a second note here and keeps beeing deleted some how???

 

Found a stack exchange post.  using this worked for me using ssh, using the beta version

ssh://git@github.com/USERNAME/REPONAME.git

 

Seems like the input is wrong when the app is used and 

account is setop?

It is usually because the spam filters do not like links, especially to sites that are of poor quality such as stack overflow and stack exchange. 

Generalised sites like these do tend to have a lot of good expertise and excellent answers.  But because they can't accurately curate their content, when they go into  more specialised areas, they get swamped by people who really have no idea what they are talking about.  

ahh, was thinking something like that. Well im no hardcore user, so i'm with those newbies which know S$#@ ;)

But wanted to give other users my solution here.

I'm using SourceTree for Mac. I had this issue for a long time, SourceTree was not able to log into Bitbucket but logging into Github etc worked fine. I just figured out that my username contained capital letters, and when logging in through SourceTree I had to enter my username in lower case only. If you came to this page and your username contains capital letter(s), try logging in with lowercase username.

 

Thanks a lot. Solved the bug (3 hrs wasted on this :/ )

 tried this and for a brief second i see my avatar when the edit screen is open, as soon as i confirm it it goes blanc again

http://situsbandarqq.com

Hi,

yesterday I solved my issue:  the reason I couldn´t connect was a special character (german umlaut) in my password that was not supported. This could be caused by a different codepage in Atlassian.

How to fix it fast and easy:   change your password -> use only supported characters for it.

Same problem here.

OS version:  macOS Sierra Version 10.12.4

SourceTree version: 2.5 (104)

I can't log in to my Bitbucket account, receive this error message:

"Could not authorize request with the available token. Please re-authenticate." 

Still having this issue with Version 2.4 (93)

Regularly prevents me from pulling changes due to 'incorrect password' error even though the password is absolutely correct.

'Use the terminal' is not a solution - the whole reason I choose to use sourcetree is so that I don't have to user the terminal. If that's the solution it might as well be suggesting to uninstall sourcetree altogether.

Try using the terminal option. The terminal never crashes, and it will allow you to enter the correct user name or to update password when needed. 

image2016-10-19 11:34:8.png

I'm having the same problem.  Sourcetree 2.1 on OSX.  Login credentials are correct.

Hi, 

I am also getting the same issue.whenI am going to login withusernameand password that time it is throwing login failed, evenIfirst logout from the Bitbucket then again login and still same problem is there.

 

 

Untitled.png

I just upgraded to a new windows 10 computer with version 1.8.2.11.  When I try to clone my project, I get the attached error.  I'm not sure what I'm doing wrong.  I have put the same password in I use with my account so I know it is correct. error.PNG

I'm using version 1.7.0.32509 and I also keep getting the login window. When I type in my password I get no feedback and after 5-10 seconds a new login window pops up. I'm 100% sure I'm typing the correct password.

Ditto for me also.  I can use the command line without any problems but not within SourceTree after the latest update.  Just had someone else try using the Mac version and it's working OK for them, so maybe just the Windows version? (1.6.24.0).

I got the same problem - both with Bitbucket and Github

Great.. how long til this gets hotfixed? I can't find any link to go back to the previous version, has anyone else?

Таже проблема после обновления до 1.6.24. С темеже данными авторизации на IDE всё работает. в Source tree увы нет. Полное удаление программы со всеми данными не помогло. Использую Windows 8.1

Ditto. After the upgrade to 1.6.24, I tried to pull latest and get prompted for network credentials. Entering the correct credentials fails.

I uninstalled SourceTree and reinstalled version 1.6.23, and now authentication is working normally

(http://downloads.atlassian.com/software/sourcetree/windows/SourceTreeSetup_1.6.23.exe)

I have some error, after update to 1.6.24, password is 100% correct (i change him on Bitbucket site now) but can`t login in SourceTree to Bitbucket

I got the same problem with 1.6.24. I reverted to the older version and it works!

Got the same problem and it is a real show stopper. We have a release tomorrow and I need to get working now.

I get the "Authentication failed" error since last update (1.6.24)
Username and password are 100% correct ( I can login to bitbucket.org )
Reboot, didn't help.

 

Just updated source tree to v1.6.24 and now I can't get authentication to commit to bitbucket.

Having the same problem as Murray Francis.

Using Windows 8.1, upgraded to v1.6.24 today and had to revert to v1.6.23 to get authenticated on my git account. Please fix this asap.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

1,431 views 1 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you