Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,323,606
Community Members
 
Community Events
168
Community Groups

Not seeing how to use an existing SSH public key on a new server

how to get an ssh public key for aws ... not for windows or linux.. but for amazon web service. 

 

the comand line doesnt work  : cat ~/.ssh/id_rsa.pub 

1 comment

Depends on your OS. See https://confluence.atlassian.com/bitbucketserver/ssh-user-keys-for-personal-use-776639793.html

Windows

cd %userprofile%/.ssh
clip < id_rsa.pub


On macOS or Linux simply run the following in a terminal:

Mac OS X

pbcopy < ~/.ssh/id_rsa.pub


Note that on Linux, you may need to download and install xclip, then use that, as shown in this code snippet:

Linux

sudo apt-get install xclip
xclip -sel clip < ~/.ssh/id_rsa.pub

 If you do not have a key, you should create one first: https://confluence.atlassian.com/bitbucketserver/creating-ssh-keys-776639788.html

Screenshot (5)_LI.jpgThank you Jobin.  

After creating a bitbucket account, on the AWS console Cloud9 in the terminal  I run this command and it worked :  

cat ~/.ssh/id_rsa.pub

 

Comment

Log in or Sign up to comment
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,856 views 3 9
Read article

Atlassian Community Events