Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


issueFieldExactMatch with special characters

Hi *,
I'm using `issueFieldExactMatch` function to really get an issue with exact name.
This works quite well until I have some special characters in searched name.

issueFunction in issueFieldExactMatch('project=RDXRAYEV and type=test','summary','test_basic_feature[check_temperature-WithSimulators]')

This throws an error: 

Reg ex compilation failure in issueFieldExactMatch function: Illegal character range near index 37 test_basic_feature[check_temperature-WithSimulators] ^

what points to the "W" string. But after more attempts it looks like the dash is the problem. I tried to escape it with double backslash, what helped me to get rid of the exception, but there were no results, even I know the issue with such name is present in the project.

Similar issues I have e.g with names like test_my_script[] . As soon as there is some text between the square brackets everything works properly.


Is there any way how to look also for text names with special characters?

2 answers

Suggest an answer

Log in or Sign up to answer

Thanks for confirmation!

yes, I tried also lowercase `w`, but doesn't work always. E.g.

issueFunction in issueFieldExactMatch('project=RDXRAYEV and type=test','summary','test_basic_feature[change_randomly-withSimulators]')

gives an error:

Reg ex compilation failure in issueFieldExactMatch function: Illegal character range near index 35 test_basic_feature[change_randomly-withSimulators] ^
0 votes
Radek Dostál
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Aug 26, 2021

Seems like a bug perhaps.


With regex match this works

issueFunction in issueFieldMatch('key = RUFF-10','summary','test_basic_feature\\[check_temperature-WithSimulators\\]')


But I can't seem to get any escapes in the issueFieldExactMatch either, it seems like a bug imo.


Lower case -w works, but no uppercase letters do.

issueFunction in issueFieldExactMatch('key = RUFF-10','summary','test_basic_feature[check_temperature-withSimulators]')


Perhaps someone from Adaptavist can check this.

AUG Leaders

Atlassian Community Events