Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Why can't I edit a post function for scriptrunner custom email?

Solitonman July 22, 2019

Hello,

I'm trying to set up a custom email post function with the scriptrunner send a custom email script.  I've gotten one to work as I wish, but I had to perform some editing to get the condition right.  Now I'm trying one with a multiple value condition and I have to make frequent changes since it's not working out the gate.

This isn't about the specifics of that, though.  In the first case and in this case, I couldn't get the editing screen to update my changes.  The initial creation of the post function worked fine, but when I create a draft workflow and try to edit the post function to send the email, I can't save my changes.  Clicking the "Update" button yields no result.  What I've ended up having to do is to delete the post function and re-create it from scratch with the updated values.

I've tried this in Edge and in Chrome, and in both cases I get no results from trying to edit this post function.  It maybe be more widespread, I've only really noticed it in this case though.  

We are on JIRA Server v 7.13

Thanks!

2 answers

Suggest an answer

Log in or Sign up to answer
1 vote
Fenny Fenny
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 19, 2019

Hi @Solitonman @Yury Lubanets ,

I have similar problem.

Have you found the solution?


Thank you.

Yury Lubanets December 20, 2019

Hi @Fenny Fenny 

No, I haven't. When I need to edit scriptrunner's email postfunction I just delete and create it again (it's ok for me because it happens not often). I hope in further versions it will be solved. 

Solitonman December 20, 2019

Something has changed in our environment, and now the editing feature is working.  I can make changes to the email post function and the saves will occur.

We're on JIRA Server v7.13.0, maybe one of the administrators made an update that fixed this for us, but I didn't get any information about it directly.  I also see that our version of ScriptRunner is 5.6.2.  I hope some of this will be useful.


Dave

1 vote
Yury Lubanets August 13, 2019

Hi @Solitonman 

We have the same issue in our prod and test environments. Probably, it is a bug.

TAGS
AUG Leaders

Atlassian Community Events